summaryrefslogtreecommitdiffstats
path: root/include/package.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-09-17 11:17:26 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-09-17 11:17:26 +0000
commitb086475e1e325a545a78ea5e136c4d97beb3445f (patch)
tree0fe96b42d4590998e2e37aa1cc6041cdb748bf94 /include/package.mk
parentd6c584651368d4d37c789a23dc54fb6056e56680 (diff)
downloadmaster-31e0f0ae-b086475e1e325a545a78ea5e136c4d97beb3445f.tar.gz
master-31e0f0ae-b086475e1e325a545a78ea5e136c4d97beb3445f.tar.bz2
master-31e0f0ae-b086475e1e325a545a78ea5e136c4d97beb3445f.zip
build: ensure that package/host-build build system code does not run in parallel, fixes rare spurious parallel build failures
SVN-Revision: 33445
Diffstat (limited to 'include/package.mk')
-rw-r--r--include/package.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/package.mk b/include/package.mk
index e93aebf67d..3ec5ffdadd 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -248,6 +248,8 @@ Build/Install=$(if $(PKG_INSTALL),$(call Build/Install/Default,))
Build/Dist=$(call Build/Dist/Default,)
Build/DistCheck=$(call Build/DistCheck/Default,)
+.NOTPARALLEL:
+
$(PACKAGE_DIR):
mkdir -p $@