summaryrefslogtreecommitdiffstats
path: root/include/package.mk
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2016-06-15 18:56:17 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2016-06-15 19:26:17 +0200
commit6fb212f2933bbbdf2935124205717c9d0ca72b32 (patch)
treeab738de0137425e43edfc90bb3bd110be2a5e4a7 /include/package.mk
parente2a9c638e7f8c108ada98a4b200581090349b03d (diff)
downloadmaster-31e0f0ae-6fb212f2933bbbdf2935124205717c9d0ca72b32.tar.gz
master-31e0f0ae-6fb212f2933bbbdf2935124205717c9d0ca72b32.tar.bz2
master-31e0f0ae-6fb212f2933bbbdf2935124205717c9d0ca72b32.zip
build: don't add -j for parallel builds with Make 4.2+
Make usually passes -j and jobserver arguments as part of MAKEFLAGS. LEDE removes MAKEFLAGS to have better control of the build, and re-adds the jobserver arguments with -j to the Make commandline where desired. Make 4.2+ behave differently with these arguments passed on the commandline than in MAKEFLAGS: -j will override the jobserver argument and the job count will be unlimited. Moving the flags to MAKEFLAGS will need many packages to be changed and tested; therefore, we opt for a less invasive change for now and just remove -j for Make 4.2+, as the jobserver argument alone is enough to enable parallel builds for these Make versions. Signed-off-by: Jo-Philipp Wich <jo@mein.io> Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Diffstat (limited to 'include/package.mk')
-rw-r--r--include/package.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/package.mk b/include/package.mk
index 092811c2c2..fa5c4e7d5d 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -17,7 +17,7 @@ PKG_USE_MIPS16 ?= 1
PKG_IREMAP ?= 1
ifneq ($(CONFIG_PKG_BUILD_USE_JOBSERVER),)
- MAKE_J:=$(if $(MAKE_JOBSERVER),$(MAKE_JOBSERVER) -j)
+ MAKE_J:=$(if $(MAKE_JOBSERVER),$(MAKE_JOBSERVER) $(if $(filter 3.% 4.0 4.1,$(MAKE_VERSION)),-j))
else
MAKE_J:=-j$(CONFIG_PKG_BUILD_JOBS)
endif