summaryrefslogtreecommitdiffstats
path: root/include/package.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-05-29 10:31:45 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-05-29 10:31:45 +0000
commit6f4cb088a0ca2c0321b41d424f112586c5e363c8 (patch)
treee5a7be68122abdc78f2c07f09b00eaec14f488d9 /include/package.mk
parent5fbc56cfdc82ed6f7226217ad82fc3872c5ac3b3 (diff)
downloadmaster-31e0f0ae-6f4cb088a0ca2c0321b41d424f112586c5e363c8.tar.gz
master-31e0f0ae-6f4cb088a0ca2c0321b41d424f112586c5e363c8.tar.bz2
master-31e0f0ae-6f4cb088a0ca2c0321b41d424f112586c5e363c8.zip
build: clean up stale files from a previous build when installing a package build to the staging dir
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 36755
Diffstat (limited to 'include/package.mk')
-rw-r--r--include/package.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/include/package.mk b/include/package.mk
index 99d2dd270e..a4f353be95 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -171,6 +171,11 @@ define Build/DefaultTargets
$(foreach hook,$(Hooks/InstallDev/Post),\
$(call $(hook),$(TMP_DIR)/stage-$(PKG_NAME),$(TMP_DIR)/stage-$(PKG_NAME)/host)$(sep)\
)
+ if [ -f $(STAGING_DIR)/packages/$(STAGING_FILES_LIST) ]; then \
+ $(SCRIPT_DIR)/clean-package.sh \
+ "$(STAGING_DIR)/packages/$(STAGING_FILES_LIST)" \
+ "$(STAGING_DIR)"; \
+ fi
if [ -d $(TMP_DIR)/stage-$(PKG_NAME) ]; then \
(cd $(TMP_DIR)/stage-$(PKG_NAME); find ./ > $(TMP_DIR)/stage-$(PKG_NAME).files); \
$(call locked, \