summaryrefslogtreecommitdiffstats
path: root/include/package.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-03-21 21:47:53 +0000
committerJohn Crispin <john@openwrt.org>2015-03-21 21:47:53 +0000
commit08ae6296ca8be090a113b69e89b1e6935e163e9c (patch)
tree0c5bb97b4dddb8aeaabd25433564bd72c234b942 /include/package.mk
parent2e15b9579916cac13d0a5e4343413e65b4056d4c (diff)
downloadmaster-31e0f0ae-08ae6296ca8be090a113b69e89b1e6935e163e9c.tar.gz
master-31e0f0ae-08ae6296ca8be090a113b69e89b1e6935e163e9c.tar.bz2
master-31e0f0ae-08ae6296ca8be090a113b69e89b1e6935e163e9c.zip
build: define STAMP_CONFIGURED recursively
Defining STAMP_CONFIGURED statically caused it not to reflect changes to PKG_CONFIG_DEPENDS made after including package.mk, like the additional options added by feeds.mk for all packages. Furthermore, as STAMP_CONFIGURED_WILDCARD was already defined recursively, the patsubst in its definition would never match, and in consequence, the stamps were never removed. This caused packages not to be rebuilt when they should have been. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net> SVN-Revision: 44927
Diffstat (limited to 'include/package.mk')
-rw-r--r--include/package.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/package.mk b/include/package.mk
index 8208e36cfc..b364c3b66a 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -98,7 +98,7 @@ ifneq ($(PREV_STAMP_PREPARED),)
else
STAMP_PREPARED=$(PKG_BUILD_DIR)/.prepared$(if $(QUILT)$(DUMP),,_$(shell $(call find_md5,${CURDIR} $(PKG_FILE_DEPENDS),))$(call confvar,$(PKG_PREPARED_DEPENDS)))
endif
-STAMP_CONFIGURED:=$(PKG_BUILD_DIR)/.configured$(if $(DUMP),,_$(call confvar,$(PKG_CONFIG_DEPENDS)))
+STAMP_CONFIGURED=$(PKG_BUILD_DIR)/.configured$(if $(DUMP),,_$(call confvar,$(PKG_CONFIG_DEPENDS)))
STAMP_CONFIGURED_WILDCARD=$(patsubst %_$(call confvar,$(PKG_CONFIG_DEPENDS)),%_*,$(STAMP_CONFIGURED))
STAMP_BUILT:=$(PKG_BUILD_DIR)/.built
STAMP_INSTALLED:=$(STAGING_DIR)/stamp/.$(PKG_NAME)_installed