summaryrefslogtreecommitdiffstats
path: root/include/package.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-03-17 02:20:34 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-03-17 02:20:34 +0000
commitddcfaeb1e516d569436c3d4d453a9573655ca375 (patch)
tree94b1169c72a68b9ef6ce9ab92aea68eb8764358a /include/package.mk
parent7ef6b7451973d0d3fd09014871e7859b6a83fb19 (diff)
downloadmaster-31e0f0ae-ddcfaeb1e516d569436c3d4d453a9573655ca375.tar.gz
master-31e0f0ae-ddcfaeb1e516d569436c3d4d453a9573655ca375.tar.bz2
master-31e0f0ae-ddcfaeb1e516d569436c3d4d453a9573655ca375.zip
move host build in packages into a separate namespace: package/<name>/host/<target> this allows dependencies between host and target packages, and saves unnecessary host builds for packages that contain both variants
SVN-Revision: 14905
Diffstat (limited to 'include/package.mk')
-rw-r--r--include/package.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/package.mk b/include/package.mk
index 7e0501c554..191dec9ca7 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -79,7 +79,7 @@ define Build/DefaultTargets
$(STAMP_CONFIGURED) : export PATH=$$(TARGET_PATH_PKG)
$(STAMP_CONFIGURED) : export CONFIG_SITE:=$$(CONFIG_SITE)
- $(STAMP_CONFIGURED): $(STAMP_PREPARED) $(HOST_STAMP_INSTALLED)
+ $(STAMP_CONFIGURED): $(STAMP_PREPARED)
$(foreach hook,$(Hooks/Configure/Pre),$(call $(hook))$(sep))
$(Build/Configure)
$(foreach hook,$(Hooks/Configure/Post),$(call $(hook))$(sep))