summaryrefslogtreecommitdiffstats
path: root/include/package.mk
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-01-08 01:49:11 +0000
committerNicolas Thill <nico@openwrt.org>2009-01-08 01:49:11 +0000
commita3edea1b9136b05edfed95b58ba33a9ff46b6587 (patch)
treed770d58fd59fc61cac796defdba965d6e1af5f71 /include/package.mk
parent001fd4384175d67eef5554613e6933ddb3c70585 (diff)
downloadmaster-31e0f0ae-a3edea1b9136b05edfed95b58ba33a9ff46b6587.tar.gz
master-31e0f0ae-a3edea1b9136b05edfed95b58ba33a9ff46b6587.tar.bz2
master-31e0f0ae-a3edea1b9136b05edfed95b58ba33a9ff46b6587.zip
add support for alternative C libraries (currently only glibc/eglibc) other (related) changes: - kernel headers are now installed using "make headers_install" on 2.6 - target names now contain an openwrt "vendor" tag (e.g. mips-openwrt-linux-gnu) - build directory names now contain gcc/libc name/version - default cpu for x86 is now i486 (required to build glibc/eglibc)
SVN-Revision: 13931
Diffstat (limited to 'include/package.mk')
-rw-r--r--include/package.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/package.mk b/include/package.mk
index 0f3d21ee9e..4e31258305 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -31,7 +31,7 @@ include $(INCLUDE_DIR)/package-bin.mk
include $(INCLUDE_DIR)/autotools.mk
override MAKEFLAGS=
-CONFIG_SITE:=$(INCLUDE_DIR)/site/$(patsubst %gnueabi,%,$(REAL_GNU_TARGET_NAME))
+CONFIG_SITE:=$(INCLUDE_DIR)/site/$(REAL_GNU_TARGET_NAME)
ifneq ($(CONFIG_LINUX_2_4),)
CONFIG_SITE:=$(subst linux-,linux2.4-,$(CONFIG_SITE))
endif