summaryrefslogtreecommitdiffstats
path: root/include/package.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-12-27 02:11:07 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-12-27 02:11:07 +0000
commit5c2991d8bc17d458831c87dd6b4d2e3e229fd6cf (patch)
tree317ca8ab3c7dc3815d35e283c7a2170051736d4b /include/package.mk
parent01dd5fc03aec5e2e0590b469bb17709dcb841861 (diff)
downloadmaster-31e0f0ae-5c2991d8bc17d458831c87dd6b4d2e3e229fd6cf.tar.gz
master-31e0f0ae-5c2991d8bc17d458831c87dd6b4d2e3e229fd6cf.tar.bz2
master-31e0f0ae-5c2991d8bc17d458831c87dd6b4d2e3e229fd6cf.zip
add improved autotools fixups
SVN-Revision: 9942
Diffstat (limited to 'include/package.mk')
-rw-r--r--include/package.mk23
1 files changed, 11 insertions, 12 deletions
diff --git a/include/package.mk b/include/package.mk
index 7e6b750da0..d5d39d8f33 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -27,6 +27,7 @@ include $(INCLUDE_DIR)/package-defaults.mk
include $(INCLUDE_DIR)/package-dumpinfo.mk
include $(INCLUDE_DIR)/package-ipkg.mk
include $(INCLUDE_DIR)/package-bin.mk
+include $(INCLUDE_DIR)/autotools.mk
override MAKEFLAGS=
export CONFIG_SITE:=$(INCLUDE_DIR)/site/$(REAL_GNU_TARGET_NAME)
@@ -50,6 +51,10 @@ define Download/default
MD5SUM:=$(PKG_MD5SUM)
endef
+define sep
+
+endef
+
define Build/DefaultTargets
$(if $(QUILT),$(Build/Quilt))
$(if $(strip $(PKG_SOURCE_URL)),$(call Download,default))
@@ -58,15 +63,21 @@ define Build/DefaultTargets
$(STAMP_PREPARED):
@-rm -rf $(PKG_BUILD_DIR)
@mkdir -p $(PKG_BUILD_DIR)
+ $(foreach hook,$(Hooks/Prepare/Pre),$(call $(hook))$(sep))
$(Build/Prepare)
+ $(foreach hook,$(Hooks/Prepare/Post),$(call $(hook))$(sep))
touch $$@
$(STAMP_CONFIGURED): $(STAMP_PREPARED)
+ $(foreach hook,$(Hooks/Configure/Pre),$(call $(hook))$(sep))
$(Build/Configure)
+ $(foreach hook,$(Hooks/Configure/Post),$(call $(hook))$(sep))
touch $$@
$(STAMP_BUILT): $(STAMP_CONFIGURED)
+ $(foreach hook,$(Hooks/Compile/Pre),$(call $(hook))$(sep))
$(Build/Compile)
+ $(foreach hook,$(Hooks/Compile/Post),$(call $(hook))$(sep))
touch $$@
$(STAMP_INSTALLED): $(STAMP_BUILT)
@@ -126,18 +137,6 @@ endif
$(if $(DUMP),,$(call Build/DefaultTargets,$(1)))
endef
-# prevent libtool from setting rpath when linking
-define libtool_disable_rpath
- find $(PKG_BUILD_DIR) -name 'libtool' | $(XARGS) \
- $(SED) 's,^hardcode_libdir_flag_spec=.*,hardcode_libdir_flag_spec=" -D__LIBTOOL_IS_A_FOOL__ ",g'
-endef
-
-# prevent libtool from linking against host development libraries
-define libtool_fixup_libdir
- find $(PKG_BUILD_DIR) -name '*.la' | $(XARGS) \
- $(SED) "s,^libdir='/usr/lib',libdir='$(strip $(1))/usr/lib',g"
-endef
-
define pkg_install_files
$(foreach install_file,$(1),$(INSTALL_DIR) $(3)/`dirname $(install_file)`; $(INSTALL_DATA) $(2)/$(install_file) $(3)/`dirname $(install_file)`;)
endef