summaryrefslogtreecommitdiffstats
path: root/include/package.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-09-01 11:03:58 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-09-01 11:03:58 +0000
commit5719247ae3fc89e58594a0fb4c5dcf4575782d5a (patch)
tree76f1b4d877ab47ac13b5cf5644356e4c764dfeb0 /include/package.mk
parent304c93e4871cb5e1fbf16921fa082ed4a1bb43c4 (diff)
downloadmaster-31e0f0ae-5719247ae3fc89e58594a0fb4c5dcf4575782d5a.tar.gz
master-31e0f0ae-5719247ae3fc89e58594a0fb4c5dcf4575782d5a.tar.bz2
master-31e0f0ae-5719247ae3fc89e58594a0fb4c5dcf4575782d5a.zip
add an extra build step Build/Install which allows you to run a make install target after the post-compile hooks have run - will be necessary for some libtool dependent stuff
SVN-Revision: 12452
Diffstat (limited to 'include/package.mk')
-rw-r--r--include/package.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/package.mk b/include/package.mk
index 8819a11564..e0f8c719f4 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -81,6 +81,8 @@ define Build/DefaultTargets
$(foreach hook,$(Hooks/Compile/Pre),$(call $(hook))$(sep))
$(Build/Compile)
$(foreach hook,$(Hooks/Compile/Post),$(call $(hook))$(sep))
+ $(Build/Install)
+ $(foreach hook,$(Hooks/Install/Post),$(call $(hook))$(sep))
touch $$@
$(STAMP_INSTALLED): $(STAMP_BUILT)