summaryrefslogtreecommitdiffstats
path: root/include/package.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-11-20 22:43:38 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-11-20 22:43:38 +0000
commit407b75436d4ead8f6211108e65cb0ed349cb7c99 (patch)
tree4081026c0dfeb488ff6b8af0399b30c840dd73d0 /include/package.mk
parente28b55f39fffe054db1a6bac193d5f0ee9221579 (diff)
downloadmaster-31e0f0ae-407b75436d4ead8f6211108e65cb0ed349cb7c99.tar.gz
master-31e0f0ae-407b75436d4ead8f6211108e65cb0ed349cb7c99.tar.bz2
master-31e0f0ae-407b75436d4ead8f6211108e65cb0ed349cb7c99.zip
fix build issues that happen when the staging dir is cleared and the build directories stay
SVN-Revision: 9588
Diffstat (limited to 'include/package.mk')
-rw-r--r--include/package.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/include/package.mk b/include/package.mk
index 049d5befef..83c3025de2 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -19,6 +19,7 @@ include $(INCLUDE_DIR)/depends.mk
STAMP_PREPARED=$(PKG_BUILD_DIR)/.prepared$(if $(QUILT)$(DUMP),,_$(shell $(call find_md5,${CURDIR} $(PKG_FILE_DEPEND),)))
STAMP_CONFIGURED:=$(PKG_BUILD_DIR)/.configured
STAMP_BUILT:=$(PKG_BUILD_DIR)/.built
+STAMP_INSTALLED:=$(STAGING_DIR)/stamp/.$(PKG_NAME)_installed
include $(INCLUDE_DIR)/download.mk
include $(INCLUDE_DIR)/quilt.mk
@@ -66,11 +67,14 @@ define Build/DefaultTargets
$(STAMP_BUILT): $(STAMP_CONFIGURED)
$(Build/Compile)
+ touch $$@
+
+ $(STAMP_INSTALLED): $(STAMP_BUILT)
$(call Build/InstallDev,$(STAGING_DIR))
touch $$@
ifdef Build/InstallDev
- compile: $(STAMP_BUILT)
+ compile: $(STAMP_INSTALLED)
endif
define Build/DefaultTargets