summaryrefslogtreecommitdiffstats
path: root/include/package.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2007-10-07 01:55:03 +0000
committerJohn Crispin <john@openwrt.org>2007-10-07 01:55:03 +0000
commit33ecac1f24723ad46d1d5e72dbcc6768f7e00642 (patch)
tree8d6860cb3f8fac37e74b76d472d5bf7b092d2dff /include/package.mk
parentcfd0fecd47ca970b7deff63c81ad1034b80e5328 (diff)
downloadmaster-31e0f0ae-33ecac1f24723ad46d1d5e72dbcc6768f7e00642.tar.gz
master-31e0f0ae-33ecac1f24723ad46d1d5e72dbcc6768f7e00642.tar.bz2
master-31e0f0ae-33ecac1f24723ad46d1d5e72dbcc6768f7e00642.zip
added a function, that packages can call to make installing files/folders much cleaner and easier
SVN-Revision: 9171
Diffstat (limited to 'include/package.mk')
-rw-r--r--include/package.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/include/package.mk b/include/package.mk
index d61eb8cf7a..6307a1f47c 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -121,6 +121,10 @@ define libtool_fixup_libdir
$(SED) "s,^libdir='/usr/lib',libdir='$(strip $(1))/usr/lib',g"
endef
+define pkg_install_files
+ $(foreach install_file,$(2),$(INSTALL_DIR) $(1)/`dirname $(install_file)`; $(CP) $(PKG_INSTALL_DIR)/$(install_file) $(1)/`dirname $(install_file)`;)
+endef
+
define Build/Prepare
$(call Build/Prepare/Default,)
endef