summaryrefslogtreecommitdiffstats
path: root/include/package-seccomp.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-03-26 10:57:56 +0000
committerJohn Crispin <john@openwrt.org>2015-03-26 10:57:56 +0000
commitd95e0687aa596342aa9e3851d9ce33443ca644d0 (patch)
tree89d7a4c7ba92e19e68a7e8731252d1c9d738b374 /include/package-seccomp.mk
parent006f8c9446c02afa6e25a08cc4c9525d369d3953 (diff)
downloadmaster-31e0f0ae-d95e0687aa596342aa9e3851d9ce33443ca644d0.tar.gz
master-31e0f0ae-d95e0687aa596342aa9e3851d9ce33443ca644d0.tar.bz2
master-31e0f0ae-d95e0687aa596342aa9e3851d9ce33443ca644d0.zip
include: add a seccomp filter install wrapper
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 45006
Diffstat (limited to 'include/package-seccomp.mk')
-rw-r--r--include/package-seccomp.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/include/package-seccomp.mk b/include/package-seccomp.mk
new file mode 100644
index 0000000000..fa49617d41
--- /dev/null
+++ b/include/package-seccomp.mk
@@ -0,0 +1,15 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+PKG_CONFIG_DEPENDS+= CONFIG_KERNEL_SECCOMP
+
+ifeq ($(CONFIG_KERNEL_SECCOMP),y)
+ define InstallSeccomp
+ $(INSTALL_DIR) $(1)/etc/seccomp
+ $(INSTALL_DATA) $(2) $(1)/etc/seccomp/
+ endef
+endif