summaryrefslogtreecommitdiffstats
path: root/include/package-ipkg.mk
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2015-01-31 08:15:46 +0000
committerNicolas Thill <nico@openwrt.org>2015-01-31 08:15:46 +0000
commitd8263c3025a726a9025b95993b6b4598e83b9545 (patch)
treeb5df44f0d2c5c7d943c13cd744afd0dde080e69f /include/package-ipkg.mk
parent9d7651b528738e9ee62b5e182f565dea24b6f09d (diff)
downloadmaster-31e0f0ae-d8263c3025a726a9025b95993b6b4598e83b9545.tar.gz
master-31e0f0ae-d8263c3025a726a9025b95993b6b4598e83b9545.tar.bz2
master-31e0f0ae-d8263c3025a726a9025b95993b6b4598e83b9545.zip
include: don't use extended regex for deps checking
Closes: #18851 Signed-off-by: Nicolas Thill <nico@openwrt.org> SVN-Revision: 44224
Diffstat (limited to 'include/package-ipkg.mk')
-rw-r--r--include/package-ipkg.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index 815aef093a..11edb9aeaa 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -66,7 +66,7 @@ ifneq ($(PKG_NAME),toolchain)
XARGS="$(XARGS)"; \
$(SCRIPT_DIR)/gen-dependencies.sh "$$(IDIR_$(1))"; \
) | while read FILE; do \
- grep -qE "^$$$$FILE$$$$" $(PKG_INFO_DIR)/$(1).provides || \
+ grep -q "^$$$$FILE$$$$" $(PKG_INFO_DIR)/$(1).provides || \
echo "$$$$FILE" >> $(PKG_INFO_DIR)/$(1).missing; \
done; \
if [ -f "$(PKG_INFO_DIR)/$(1).missing" ]; then \