summaryrefslogtreecommitdiffstats
path: root/include/package-ipkg.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-01-29 21:59:17 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-01-29 21:59:17 +0000
commitc3787d4c0c1d6707d06181628794367395f536e7 (patch)
treea0e692feaaebdaef9e6509a63ea67873b52b42e9 /include/package-ipkg.mk
parent2e5411518fa6a5bed67aa9ea7e8ca87b273ab509 (diff)
downloadmaster-31e0f0ae-c3787d4c0c1d6707d06181628794367395f536e7.tar.gz
master-31e0f0ae-c3787d4c0c1d6707d06181628794367395f536e7.tar.bz2
master-31e0f0ae-c3787d4c0c1d6707d06181628794367395f536e7.zip
include: use anchored patterns for dependency checking
Anchor search pattern when testing dependencies, otherwise the check may succeed in cases where it shouldn't, e.g. when matching "udp_tunnel.ko" against "ip6_udp_tunnel.ko". Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 44207
Diffstat (limited to 'include/package-ipkg.mk')
-rw-r--r--include/package-ipkg.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index 77eaeb824f..815aef093a 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -66,7 +66,7 @@ ifneq ($(PKG_NAME),toolchain)
XARGS="$(XARGS)"; \
$(SCRIPT_DIR)/gen-dependencies.sh "$$(IDIR_$(1))"; \
) | while read FILE; do \
- grep -q "$$$$FILE" $(PKG_INFO_DIR)/$(1).provides || \
+ grep -qE "^$$$$FILE$$$$" $(PKG_INFO_DIR)/$(1).provides || \
echo "$$$$FILE" >> $(PKG_INFO_DIR)/$(1).missing; \
done; \
if [ -f "$(PKG_INFO_DIR)/$(1).missing" ]; then \