summaryrefslogtreecommitdiffstats
path: root/include/package-ipkg.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-10-22 08:57:50 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-10-22 08:57:50 +0000
commit949ab1487f5a54935469011f068bb6de9ff9cee8 (patch)
treeb8a118aa8b30b99f8ed1a3385709b45fd304ce1b /include/package-ipkg.mk
parentd8278dee4db4f9267be75fd56aa7187d062106bd (diff)
downloadmaster-31e0f0ae-949ab1487f5a54935469011f068bb6de9ff9cee8.tar.gz
master-31e0f0ae-949ab1487f5a54935469011f068bb6de9ff9cee8.tar.bz2
master-31e0f0ae-949ab1487f5a54935469011f068bb6de9ff9cee8.zip
build: only print skipped packages that were selected
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 43023
Diffstat (limited to 'include/package-ipkg.mk')
-rw-r--r--include/package-ipkg.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index b8c8cd6f99..13bb7c7d42 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -109,7 +109,7 @@ ifeq ($(DUMP),)
echo "$(1)" >> $(PKG_INSTALL_STAMP)
endif
else
- $$(info WARNING: skipping $(1) -- package not selected)
+ $(if $(CONFIG_PACKAGE_$(1)),$$(info WARNING: skipping $(1) -- package not selected))
endif
endif
endif