summaryrefslogtreecommitdiffstats
path: root/include/package-ipkg.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2016-04-06 21:55:44 +0200
committerJo-Philipp Wich <jo@mein.io>2016-04-06 21:55:44 +0200
commit5170393f8cae3c5acac61bd6ac6e127f9727cee4 (patch)
tree23f3c4ec47a47069da63dc97b15bb1d10f021776 /include/package-ipkg.mk
parent941fc5e8c8fd48c31c97c9194d1bed786145f978 (diff)
downloadmaster-31e0f0ae-5170393f8cae3c5acac61bd6ac6e127f9727cee4.tar.gz
master-31e0f0ae-5170393f8cae3c5acac61bd6ac6e127f9727cee4.tar.bz2
master-31e0f0ae-5170393f8cae3c5acac61bd6ac6e127f9727cee4.zip
include: choose package output directory based on repository info
Use the new repository metadata field to choose the output directory of the final package archives. Non-sharable packages will be placed in the per-target package directory while the rest will be placed in a per-repository sub directory within the $OUTPUT_DIR/packages/$CPU_TYPE/ prefix. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'include/package-ipkg.mk')
-rw-r--r--include/package-ipkg.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index eb4c874047..a86f401805 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -88,7 +88,7 @@ _endef=endef
ifeq ($(DUMP),)
define BuildTarget/ipkg
- PDIR_$(1):=$(call FeedPackageDir,$(1))
+ PDIR_$(1):=$(call FeedPackageDir,$(1),$(PKG_FLAGS),$(SECTION))
IPKG_$(1):=$$(PDIR_$(1))/$(1)_$(VERSION)_$(PKGARCH).ipk
IDIR_$(1):=$(PKG_BUILD_DIR)/ipkg-$(PKGARCH)/$(1)
KEEP_$(1):=$(strip $(call Package/$(1)/conffiles))