summaryrefslogtreecommitdiffstats
path: root/include/package-ipkg.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-10-24 09:24:51 +0000
committerJo-Philipp Wich <jow@openwrt.org>2014-10-24 09:24:51 +0000
commit4de4827ddc9d64a055bcfdb6a65f0e427d36e85e (patch)
tree0ebfdf8cdb752f036f7a84fe0c7d8edea1cba85e /include/package-ipkg.mk
parent16e2c7ab80e7e4ff29ac88df9e7edaa70f7dc991 (diff)
downloadmaster-31e0f0ae-4de4827ddc9d64a055bcfdb6a65f0e427d36e85e.tar.gz
master-31e0f0ae-4de4827ddc9d64a055bcfdb6a65f0e427d36e85e.tar.bz2
master-31e0f0ae-4de4827ddc9d64a055bcfdb6a65f0e427d36e85e.zip
include: unbreak conffiles, postinst & prerm exports
Changeset r43017 reworked the ipkg control metadata generation but broke the export of conffiles, postinst and prerm defines. Change the code back to rely on shvar and shexport, this is required to properly output multiline contents. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 43041
Diffstat (limited to 'include/package-ipkg.mk')
-rw-r--r--include/package-ipkg.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index 13bb7c7d42..77eaeb824f 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -13,10 +13,14 @@ IPKG_BUILD:= \
IPKG_STATE_DIR:=$(TARGET_DIR)/usr/lib/opkg
+# 1: package name
+# 2: variable name
+# 3: variable suffix
define BuildIPKGVariable
ifdef Package/$(1)/$(2)
$$(IPKG_$(1)) : VAR_$(2)$(3)=$$(Package/$(1)/$(2))
- $(1)_COMMANDS += echo "$$$$$(2)$(3)" > $(2)$(3);
+ $(call shexport,Package/$(1)/$(2))
+ $(1)_COMMANDS += echo "$$$$$$$$$(call shvar,Package/$(1)/$(2))" > $(2)$(3);
endif
endef