summaryrefslogtreecommitdiffstats
path: root/include/package-ipkg.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-02-03 10:11:06 +0000
committerJohn Crispin <john@openwrt.org>2015-02-03 10:11:06 +0000
commit4a1d29c5fce88fd62ed479dc5dd1bcfd17fbb5b2 (patch)
tree0fdc890b7328f7caa1bd6f1e308d91f4dd19616e /include/package-ipkg.mk
parentfd2689ecfc5c31e138b5b944c373f6b512237eca (diff)
downloadmaster-31e0f0ae-4a1d29c5fce88fd62ed479dc5dd1bcfd17fbb5b2.tar.gz
master-31e0f0ae-4a1d29c5fce88fd62ed479dc5dd1bcfd17fbb5b2.tar.bz2
master-31e0f0ae-4a1d29c5fce88fd62ed479dc5dd1bcfd17fbb5b2.zip
Fix possible fail to check for dependencies
Few characters in filenames (a plus sign, a dot) can be interpreted specially by grep. This can lead to the omission of missing package dependency. For example if we would have "some.file.so" then it matches also "some2file.so". -F switch off special meaning of any character and -x match against whole line. Signed-off-by: SÅ‚awomir Demeszko <s.demeszko@wireless-instruments.com> SVN-Revision: 44247
Diffstat (limited to 'include/package-ipkg.mk')
-rw-r--r--include/package-ipkg.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index 11edb9aeaa..b7dc0ad1e8 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -66,7 +66,7 @@ ifneq ($(PKG_NAME),toolchain)
XARGS="$(XARGS)"; \
$(SCRIPT_DIR)/gen-dependencies.sh "$$(IDIR_$(1))"; \
) | while read FILE; do \
- grep -q "^$$$$FILE$$$$" $(PKG_INFO_DIR)/$(1).provides || \
+ grep -qxF "$$$$FILE" $(PKG_INFO_DIR)/$(1).provides || \
echo "$$$$FILE" >> $(PKG_INFO_DIR)/$(1).missing; \
done; \
if [ -f "$(PKG_INFO_DIR)/$(1).missing" ]; then \