summaryrefslogtreecommitdiffstats
path: root/include/package-ipkg.mk
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2007-08-24 12:05:30 +0000
committerNicolas Thill <nico@openwrt.org>2007-08-24 12:05:30 +0000
commite9fba2c56b6252c43693d627c90272bc748e9c30 (patch)
tree7ef7de929d4c9f5ff709bd5e0a21a2bdafe84e3b /include/package-ipkg.mk
parentfa3d3f60227179ffe733cbfeb354eba3ed118630 (diff)
downloadmaster-31e0f0ae-e9fba2c56b6252c43693d627c90272bc748e9c30.tar.gz
master-31e0f0ae-e9fba2c56b6252c43693d627c90272bc748e9c30.tar.bz2
master-31e0f0ae-e9fba2c56b6252c43693d627c90272bc748e9c30.zip
combine the 3 find in a single one
SVN-Revision: 8477
Diffstat (limited to 'include/package-ipkg.mk')
-rw-r--r--include/package-ipkg.mk4
1 files changed, 1 insertions, 3 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index 597f5f87c3..36f030375d 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -63,9 +63,7 @@ ifeq ($(DUMP),)
$$(IPKG_$(1)): $(PKG_BUILD_DIR)/.built $$(IDIR_$(1))/CONTROL/control
$(call Package/$(1)/install,$$(IDIR_$(1)))
mkdir -p $(PACKAGE_DIR)
- -find $$(IDIR_$(1)) -name CVS | $(XARGS) rm -rf
- -find $$(IDIR_$(1)) -name .svn | $(XARGS) rm -rf
- -find $$(IDIR_$(1)) -name '.#*' | $(XARGS) rm -f
+ -find $$(IDIR_$(1)) -name 'CVS' -o -name '.svn' -o -name '.#*' | $(XARGS) rm -rf
$(RSTRIP) $$(IDIR_$(1))
$(IPKG_BUILD) $$(IDIR_$(1)) $(PACKAGE_DIR)
@[ -f $$(IPKG_$(1)) ] || false