summaryrefslogtreecommitdiffstats
path: root/include/package-ipkg.mk
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2007-08-25 11:55:01 +0000
committerNicolas Thill <nico@openwrt.org>2007-08-25 11:55:01 +0000
commitd21941ca4d7b8ec88ee55271f2ef00dd5cbac9ca (patch)
treedc9086e57f650f736a771ef042351890ca6cb0a3 /include/package-ipkg.mk
parent34c758830a5900c1e2eed821499ee90989c21c11 (diff)
downloadmaster-31e0f0ae-d21941ca4d7b8ec88ee55271f2ef00dd5cbac9ca.tar.gz
master-31e0f0ae-d21941ca4d7b8ec88ee55271f2ef00dd5cbac9ca.tar.bz2
master-31e0f0ae-d21941ca4d7b8ec88ee55271f2ef00dd5cbac9ca.zip
move ipkg.conf creation from tools/ipkg-utils to include/package-ipkg.mk
SVN-Revision: 8481
Diffstat (limited to 'include/package-ipkg.mk')
-rw-r--r--include/package-ipkg.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index 36f030375d..c67ee4b8ae 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -60,7 +60,7 @@ ifeq ($(DUMP),)
$($(1)_COMMANDS) \
)
- $$(IPKG_$(1)): $(PKG_BUILD_DIR)/.built $$(IDIR_$(1))/CONTROL/control
+ $$(IPKG_$(1)): $(STAGING_DIR)/etc/ipkg.conf $(PKG_BUILD_DIR)/.built $$(IDIR_$(1))/CONTROL/control
$(call Package/$(1)/install,$$(IDIR_$(1)))
mkdir -p $(PACKAGE_DIR)
-find $$(IDIR_$(1)) -name 'CVS' -o -name '.svn' -o -name '.#*' | $(XARGS) rm -rf
@@ -71,6 +71,11 @@ ifeq ($(DUMP),)
$$(INFO_$(1)): $$(IPKG_$(1))
$(IPKG) install $$(IPKG_$(1))
+ $(STAGING_DIR)/etc/ipkg.conf:
+ mkdir -p $(STAGING_DIR)/etc
+ echo "dest root /" > $(STAGING_DIR)/etc/ipkg.conf
+ echo "option offline_root $(TARGET_DIR)" >> $(STAGING_DIR)/etc/ipkg.conf
+
$(1)-clean:
rm -f $(PACKAGE_DIR)/$(1)_*