summaryrefslogtreecommitdiffstats
path: root/include/package-ipkg.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-09-28 01:23:56 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-09-28 01:23:56 +0000
commit800ef0f56ca5971811267b5639c7895c2d569491 (patch)
tree4223d1f8eb3174463a4f20bc90c8e68d6eb13b19 /include/package-ipkg.mk
parentbb402acf616778e36b0d0b24c71167407875fea5 (diff)
downloadmaster-31e0f0ae-800ef0f56ca5971811267b5639c7895c2d569491.tar.gz
master-31e0f0ae-800ef0f56ca5971811267b5639c7895c2d569491.tar.bz2
master-31e0f0ae-800ef0f56ca5971811267b5639c7895c2d569491.zip
some minor fixes, cleanups, package build abstraction
SVN-Revision: 9051
Diffstat (limited to 'include/package-ipkg.mk')
-rw-r--r--include/package-ipkg.mk5
1 files changed, 1 insertions, 4 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index f75c0a23f3..16378a0f0e 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -23,7 +23,7 @@ define BuildIPKGVariable
endef
ifeq ($(DUMP),)
- define BuildIPKG
+ define BuildTarget/ipkg
IPKG_$(1):=$(PACKAGE_DIR)/$(1)_$(VERSION)_$(PKGARCH).ipk
IDIR_$(1):=$(PKG_BUILD_DIR)/ipkg/$(1)
INFO_$(1):=$(IPKG_STATE_DIR)/info/$(1).list
@@ -92,9 +92,6 @@ ifeq ($(DUMP),)
$(PKG_BUILD_DIR)/.version-$(1)_$(VERSION)_$(PKGARCH): $(STAMP_PREPARED)
-@rm -f $(PKG_BUILD_DIR)/.version-$(1)_* 2>/dev/null
@touch $$@
-
- $$(eval $$(call Build/DefaultTargets,$(1)))
-
endef
$(STAGING_DIR)/etc/ipkg.conf: