summaryrefslogtreecommitdiffstats
path: root/include/package-ipkg.mk
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-04-02 16:09:15 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-04-02 16:09:15 +0000
commit6cd84c68386d614b4838346b8b16f0431bd07e3e (patch)
tree658bde36cb97d078f983ececc1bba6953fb84eeb /include/package-ipkg.mk
parent423af6adca85911671066465f68402da4f933622 (diff)
downloadmaster-31e0f0ae-6cd84c68386d614b4838346b8b16f0431bd07e3e.tar.gz
master-31e0f0ae-6cd84c68386d614b4838346b8b16f0431bd07e3e.tar.bz2
master-31e0f0ae-6cd84c68386d614b4838346b8b16f0431bd07e3e.zip
Use find -exec instead of xargs
SVN-Revision: 6837
Diffstat (limited to 'include/package-ipkg.mk')
-rw-r--r--include/package-ipkg.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index 8d6f1956f8..d824d268f4 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -71,9 +71,9 @@ ifeq ($(DUMP),)
$$(IPKG_$(1)): $(PKG_BUILD_DIR)/.built $$(IDIR_$(1))/CONTROL/control
$(call Package/$(1)/install,$$(IDIR_$(1)))
mkdir -p $(PACKAGE_DIR)
- -find $$(IDIR_$(1)) -name CVS | xargs rm -rf
- -find $$(IDIR_$(1)) -name .svn | xargs rm -rf
- -find $$(IDIR_$(1)) -name '.#*' | xargs rm -f
+ -find $$(IDIR_$(1)) -name CVS -exec rm -rf {} \;
+ -find $$(IDIR_$(1)) -name .svn -exec rm -rf {} \;
+ -find $$(IDIR_$(1)) -name '.#*' -exec rm -f {} \;
$(RSTRIP) $$(IDIR_$(1))
$(IPKG_BUILD) $$(IDIR_$(1)) $(PACKAGE_DIR)
@[ -f $$(IPKG_$(1)) ] || false