summaryrefslogtreecommitdiffstats
path: root/include/package-ipkg.mk
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2007-09-03 06:46:44 +0000
committerNicolas Thill <nico@openwrt.org>2007-09-03 06:46:44 +0000
commit3f80599cdadeb61589776ac3b6caa85e2ddac7a0 (patch)
tree073d9f80dfe250b556c82b69c05e0ed047b4507c /include/package-ipkg.mk
parent9400ad240fe6b177ae1e9aeb85ea4314c3c4d7db (diff)
downloadmaster-31e0f0ae-3f80599cdadeb61589776ac3b6caa85e2ddac7a0.tar.gz
master-31e0f0ae-3f80599cdadeb61589776ac3b6caa85e2ddac7a0.tar.bz2
master-31e0f0ae-3f80599cdadeb61589776ac3b6caa85e2ddac7a0.zip
move ipkg related vars from ./rules.mk to ./include/package-ipkg.mk
SVN-Revision: 8581
Diffstat (limited to 'include/package-ipkg.mk')
-rw-r--r--include/package-ipkg.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index cc9a780147..452ae5032d 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -5,6 +5,18 @@
# See /LICENSE for more information.
#
+# where to build (and put) .ipk packages
+IPKG:= \
+ IPKG_TMP=$(TMP_DIR)/ipkg \
+ IPKG_INSTROOT=$(TARGET_DIR) \
+ IPKG_CONF_DIR=$(STAGING_DIR)/etc \
+ IPKG_OFFLINE_ROOT=$(TARGET_DIR) \
+ $(SCRIPT_DIR)/ipkg -force-defaults -force-depends
+
+# invoke ipkg-build with some default options
+IPKG_BUILD:= \
+ ipkg-build -c -o 0 -g 0
+
define BuildIPKGVariable
$(call shexport,Package/$(1)/$(2))
$(1)_COMMANDS += var2file "$(call shvar,Package/$(1)/$(2))" $(2);