summaryrefslogtreecommitdiffstats
path: root/include/package-ipkg.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-04-12 19:18:38 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-04-12 19:18:38 +0000
commit3e91dd1bd509f3691a65b79d8ef2d02630aae479 (patch)
treecbe67a06b905c9400f885f9ee0b964548591a9ab /include/package-ipkg.mk
parentf3f941db39b21bdc1d629bac281f53ffb2a5eea1 (diff)
downloadmaster-31e0f0ae-3e91dd1bd509f3691a65b79d8ef2d02630aae479.tar.gz
master-31e0f0ae-3e91dd1bd509f3691a65b79d8ef2d02630aae479.tar.bz2
master-31e0f0ae-3e91dd1bd509f3691a65b79d8ef2d02630aae479.zip
revert find | xargs => find | exec changes - this is completely unnecessary and introduces additional dependencies that we do not need
SVN-Revision: 6942
Diffstat (limited to 'include/package-ipkg.mk')
-rw-r--r--include/package-ipkg.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index 8b317065bf..86c802289c 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -71,9 +71,9 @@ ifeq ($(DUMP),)
$$(IPKG_$(1)): $(PKG_BUILD_DIR)/.built $$(IDIR_$(1))/CONTROL/control
$(call Package/$(1)/install,$$(IDIR_$(1)))
mkdir -p $(PACKAGE_DIR)
- -find $$(IDIR_$(1)) -name CVS -exec rm -rf {} +
- -find $$(IDIR_$(1)) -name .svn -exec rm -rf {} +
- -find $$(IDIR_$(1)) -name '.#*' -exec rm -f {} +
+ -find $$(IDIR_$(1)) -name CVS | xargs -r rm -rf
+ -find $$(IDIR_$(1)) -name .svn | xargs -r rm -rf
+ -find $$(IDIR_$(1)) -name '.#*' | xargs -r rm -f
$(RSTRIP) $$(IDIR_$(1))
$(IPKG_BUILD) $$(IDIR_$(1)) $(PACKAGE_DIR)
@[ -f $$(IPKG_$(1)) ] || false