summaryrefslogtreecommitdiffstats
path: root/include/package-ipkg.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-03-16 03:02:31 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-03-16 03:02:31 +0000
commit2c62bddcfe20dc4691d13995bfe8c6e3d869d62f (patch)
tree1d41250dcc9cac9ed489fecf0f3eb42b8ecc69bb /include/package-ipkg.mk
parent7b1a36cab40624bc52a6475633d06cfb4ba11527 (diff)
downloadmaster-31e0f0ae-2c62bddcfe20dc4691d13995bfe8c6e3d869d62f.tar.gz
master-31e0f0ae-2c62bddcfe20dc4691d13995bfe8c6e3d869d62f.tar.bz2
master-31e0f0ae-2c62bddcfe20dc4691d13995bfe8c6e3d869d62f.zip
Add an 'Image Configuration' menu to menuconfig Packages can export a list of config options with labels and data types through the metadata. The selected config values will be exported to the target filesystem in /etc/uci-defaults and applied on the first boot.
SVN-Revision: 6572
Diffstat (limited to 'include/package-ipkg.mk')
-rw-r--r--include/package-ipkg.mk14
1 files changed, 8 insertions, 6 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index 0d6ab8af91..0f98dcfe14 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -54,12 +54,14 @@ define BuildIPKG
done; \
echo "Depends: $$$$DEPENDS" >> $$(IDIR_$(1))/CONTROL/control; \
)
- echo "Source: $(SOURCE)" >> $$(IDIR_$(1))/CONTROL/control
- echo "Section: $(SECTION)" >> $$(IDIR_$(1))/CONTROL/control
- echo "Priority: $(PRIORITY)" >> $$(IDIR_$(1))/CONTROL/control
- echo "Maintainer: $(MAINTAINER)" >> $$(IDIR_$(1))/CONTROL/control
- echo "Architecture: $(PKGARCH)" >> $$(IDIR_$(1))/CONTROL/control
- echo "Description: $(DESCRIPTION)" | sed -e 's,\\,\n,g' | sed -e 's,^[[:space:]]*$$$$, .,g' >> $$(IDIR_$(1))/CONTROL/control
+ ( \
+ echo "Source: $(SOURCE)"; \
+ echo "Section: $(SECTION)"; \
+ echo "Priority: $(PRIORITY)"; \
+ echo "Maintainer: $(MAINTAINER)"; \
+ echo "Architecture: $(PKGARCH)"; \
+ echo -n "Description: "; getvar $(call shvar,Package/$(1)/description) | sed -e 's,^[[:space:]]*, ,g'; \
+ ) >> $$(IDIR_$(1))/CONTROL/control
chmod 644 $$(IDIR_$(1))/CONTROL/control
(cd $$(IDIR_$(1))/CONTROL; \
$($(1)_COMMANDS) \