summaryrefslogtreecommitdiffstats
path: root/include/package-ipkg.mk
diff options
context:
space:
mode:
authorMike Baker <mbm@openwrt.org>2007-04-03 11:56:08 +0000
committerMike Baker <mbm@openwrt.org>2007-04-03 11:56:08 +0000
commit0359c6222e7253eed3c7a0e4b565c1d0608720e0 (patch)
tree2d6ca027d11f1e885c98d0b7ec157370d4ef7bad /include/package-ipkg.mk
parent3ce8de018e45b1e92243a50a6bde51a56b994381 (diff)
downloadmaster-31e0f0ae-0359c6222e7253eed3c7a0e4b565c1d0608720e0.tar.gz
master-31e0f0ae-0359c6222e7253eed3c7a0e4b565c1d0608720e0.tar.bz2
master-31e0f0ae-0359c6222e7253eed3c7a0e4b565c1d0608720e0.zip
Using find's -exec to remove directories causes 'not found' errors when find tries to search the removed directory. Hopefully fixed now.
SVN-Revision: 6849
Diffstat (limited to 'include/package-ipkg.mk')
-rw-r--r--include/package-ipkg.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index d824d268f4..8b317065bf 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -71,9 +71,9 @@ ifeq ($(DUMP),)
$$(IPKG_$(1)): $(PKG_BUILD_DIR)/.built $$(IDIR_$(1))/CONTROL/control
$(call Package/$(1)/install,$$(IDIR_$(1)))
mkdir -p $(PACKAGE_DIR)
- -find $$(IDIR_$(1)) -name CVS -exec rm -rf {} \;
- -find $$(IDIR_$(1)) -name .svn -exec rm -rf {} \;
- -find $$(IDIR_$(1)) -name '.#*' -exec rm -f {} \;
+ -find $$(IDIR_$(1)) -name CVS -exec rm -rf {} +
+ -find $$(IDIR_$(1)) -name .svn -exec rm -rf {} +
+ -find $$(IDIR_$(1)) -name '.#*' -exec rm -f {} +
$(RSTRIP) $$(IDIR_$(1))
$(IPKG_BUILD) $$(IDIR_$(1)) $(PACKAGE_DIR)
@[ -f $$(IPKG_$(1)) ] || false