summaryrefslogtreecommitdiffstats
path: root/include/package-dumpinfo.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-10-26 16:57:33 +0000
committerJohn Crispin <john@openwrt.org>2014-10-26 16:57:33 +0000
commiteb738f52750451fc1083f38f8c5cb77220e49d84 (patch)
tree650f6810ef068bcc24cf964afb561ca67e9f1796 /include/package-dumpinfo.mk
parentf9a06347df9645f0587990135ebb7dd671371015 (diff)
downloadmaster-31e0f0ae-eb738f52750451fc1083f38f8c5cb77220e49d84.tar.gz
master-31e0f0ae-eb738f52750451fc1083f38f8c5cb77220e49d84.tar.bz2
master-31e0f0ae-eb738f52750451fc1083f38f8c5cb77220e49d84.zip
generate list of license information for packages
Many packages define already metadata about their license (PKG_LICENSE), but this is only included in the ipk files. This change allows to create the information also on the build-host, to get an overview on the used licenses. In the full list, also all packages without this info are shown Signed-off-by: Thomas Langer <thomas.langer@lantiq.com> SVN-Revision: 43070
Diffstat (limited to 'include/package-dumpinfo.mk')
-rw-r--r--include/package-dumpinfo.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/include/package-dumpinfo.mk b/include/package-dumpinfo.mk
index 26c8d3199d..b6e2f0f794 100644
--- a/include/package-dumpinfo.mk
+++ b/include/package-dumpinfo.mk
@@ -45,7 +45,9 @@ Title: $(TITLE)
Maintainer: $(MAINTAINER)
$(if $(USERID),Require-User: $(USERID)
)Source: $(PKG_SOURCE)
-Type: $(if $(Package/$(1)/targets),$(Package/$(1)/targets),$(if $(PKG_TARGETS),$(PKG_TARGETS),ipkg))
+$(if $(PKG_LICENSE),License: $(PKG_LICENSE)
+)$(if $(PKG_LICENSE_FILES),LicenseFiles: $(PKG_LICENSE_FILES)
+)Type: $(if $(Package/$(1)/targets),$(Package/$(1)/targets),$(if $(PKG_TARGETS),$(PKG_TARGETS),ipkg))
$(if $(KCONFIG),Kernel-Config: $(KCONFIG)
)$(if $(BUILDONLY),Build-Only: $(BUILDONLY)
)$(if $(HIDDEN),Hidden: $(HIDDEN)