summaryrefslogtreecommitdiffstats
path: root/include/package-defaults.mk
diff options
context:
space:
mode:
authorTravis Kemen <thepeople@openwrt.org>2010-03-05 20:19:48 +0000
committerTravis Kemen <thepeople@openwrt.org>2010-03-05 20:19:48 +0000
commite09067b221cbea860a7d830dc84a259810f1501d (patch)
treee7bfcdde98978ff22f7f894e687fe498a4e2071f /include/package-defaults.mk
parentcf7199f48b5ef5edbeca7b0d02e1c448c8e1785d (diff)
downloadmaster-31e0f0ae-e09067b221cbea860a7d830dc84a259810f1501d.tar.gz
master-31e0f0ae-e09067b221cbea860a7d830dc84a259810f1501d.tar.bz2
master-31e0f0ae-e09067b221cbea860a7d830dc84a259810f1501d.zip
The attached patch replaces $(1) install by $(if $(1), $(1), install) in the definition, in order to be able to specify an install rule, which is not always called install (example: trunk/package/ncurses/Makefile has rules called install.libs and install.data).
Then its possible to do this in ncurses Makefile: define Build/Install $(call Build/Install/Default, install.libs install.data) endef This patch does not affect anything else, as if no parameter is given, it will use install as before. -Raphael SVN-Revision: 19996
Diffstat (limited to 'include/package-defaults.mk')
-rw-r--r--include/package-defaults.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/package-defaults.mk b/include/package-defaults.mk
index 017a86d1e8..ecc3af499f 100644
--- a/include/package-defaults.mk
+++ b/include/package-defaults.mk
@@ -122,7 +122,7 @@ define Build/Install/Default
$(MAKE_VARS) \
$(MAKE) -C $(PKG_BUILD_DIR)/$(MAKE_PATH) \
$(MAKE_INSTALL_FLAGS) \
- $(1) install;
+ $(if $(1), $(1), install);
endef
define Build/Dist/Default