summaryrefslogtreecommitdiffstats
path: root/include/package-defaults.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-09-19 15:30:40 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-09-19 15:30:40 +0000
commitb06f4dc9726e5ac6667bf9600b99a4120a3a5b9c (patch)
treeadcbc5a312d51ea1e95b78eeceb7deaa57f233c8 /include/package-defaults.mk
parentc7f0f973aba1581777d667ca746bbb5394eef818 (diff)
downloadmaster-31e0f0ae-b06f4dc9726e5ac6667bf9600b99a4120a3a5b9c.tar.gz
master-31e0f0ae-b06f4dc9726e5ac6667bf9600b99a4120a3a5b9c.tar.bz2
master-31e0f0ae-b06f4dc9726e5ac6667bf9600b99a4120a3a5b9c.zip
make packages depend on +librt and +libpthread by default if eglibc is in use
SVN-Revision: 33480
Diffstat (limited to 'include/package-defaults.mk')
-rw-r--r--include/package-defaults.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/include/package-defaults.mk b/include/package-defaults.mk
index c3496767cf..37f814da8c 100644
--- a/include/package-defaults.mk
+++ b/include/package-defaults.mk
@@ -5,8 +5,10 @@
# See /LICENSE for more information.
#
+PKG_DEFAULT_DEPENDS = +libc +USE_EGLIBC:librt +USE_EGLIBC:libpthread
+
ifneq ($(PKG_NAME),toolchain)
- PKG_FIXUP_DEPENDS = $(if $(filter kmod-%,$(1)),$(2),+libc $(filter-out +libc,$(2)))
+ PKG_FIXUP_DEPENDS = $(if $(filter kmod-%,$(1)),$(2),$(PKG_DEFAULT_DEPENDS) $(filter-out $(PKG_DEFAULT_DEPENDS),$(2)))
else
PKG_FIXUP_DEPENDS = $(2)
endif