summaryrefslogtreecommitdiffstats
path: root/include/package-defaults.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-20 16:50:50 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-20 16:50:50 +0000
commit7dad0f6fe4c4eafae35ac7c3a368b1034cccc2d1 (patch)
tree1e9ccfa5f7d06215c4a36c83792a21c18838da19 /include/package-defaults.mk
parent9143cf5fc9e06af4a9bcf07f0009666ccf66961f (diff)
downloadmaster-31e0f0ae-7dad0f6fe4c4eafae35ac7c3a368b1034cccc2d1.tar.gz
master-31e0f0ae-7dad0f6fe4c4eafae35ac7c3a368b1034cccc2d1.tar.bz2
master-31e0f0ae-7dad0f6fe4c4eafae35ac7c3a368b1034cccc2d1.zip
build: add optional dependency on libssp to all non-kernel packages
When enabling SSP_SUPPORT, a lot of packages fail during compile phase with the following error: Package X is missing dependencies for the following libraries: libssp.so.0 This can be solved by adding an optional dependency on libssp to all those packages, but as there are quite a few packages both in OpenWrt core and in the package repository, it might make sense to add this optional dependency to all non-kernel packages, instead of polluting lots of package dependency lines with it. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be> SVN-Revision: 44911
Diffstat (limited to 'include/package-defaults.mk')
-rw-r--r--include/package-defaults.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/package-defaults.mk b/include/package-defaults.mk
index a94f2a4c06..9567e04a7a 100644
--- a/include/package-defaults.mk
+++ b/include/package-defaults.mk
@@ -5,7 +5,7 @@
# See /LICENSE for more information.
#
-PKG_DEFAULT_DEPENDS = +libc +USE_GLIBC:librt +USE_GLIBC:libpthread
+PKG_DEFAULT_DEPENDS = +libc +SSP_SUPPORT:libssp +USE_GLIBC:librt +USE_GLIBC:libpthread
ifneq ($(PKG_NAME),toolchain)
PKG_FIXUP_DEPENDS = $(if $(filter kmod-%,$(1)),$(2),$(PKG_DEFAULT_DEPENDS) $(filter-out $(PKG_DEFAULT_DEPENDS),$(2)))