summaryrefslogtreecommitdiffstats
path: root/include/package-defaults.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-02-23 17:32:04 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-02-23 17:32:04 +0000
commit623825103e17a975f36854b362f17f8d26557828 (patch)
treeea2d52a4264b2bdbee20d394b449610bb7f75e48 /include/package-defaults.mk
parentf587bacc264012658b9f629300cc9a46100c2e5a (diff)
downloadmaster-31e0f0ae-623825103e17a975f36854b362f17f8d26557828.tar.gz
master-31e0f0ae-623825103e17a975f36854b362f17f8d26557828.tar.bz2
master-31e0f0ae-623825103e17a975f36854b362f17f8d26557828.zip
build: allow packages to declare ABI versions to detect necessary package rebuilds
If a package directly depends on another package that recently changed its ABI version, it will be cleaned up and rebuilt (assuming quilt is not used). This helps with packages that have no stable ABI, e.g. libubox, ubus, etc. Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 39720
Diffstat (limited to 'include/package-defaults.mk')
-rw-r--r--include/package-defaults.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/package-defaults.mk b/include/package-defaults.mk
index 0505a43c4f..62ccbb93ef 100644
--- a/include/package-defaults.mk
+++ b/include/package-defaults.mk
@@ -32,6 +32,7 @@ define Package/Default
else
VERSION:=$(PKG_RELEASE)
endif
+ ABI_VERSION:=
ifneq ($(PKG_FLAGS),)
PKGFLAGS:=$(PKG_FLAGS)
else