summaryrefslogtreecommitdiffstats
path: root/include/package-bin.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-05-15 15:57:00 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-05-15 15:57:00 +0000
commit73b78d4a75e61854b06bc33af78fd93780a438a5 (patch)
tree682b79214052c50a1cd983f4161861e71c22fb81 /include/package-bin.mk
parent48e4708a34a37be043ae0471047127430702b39a (diff)
downloadmaster-31e0f0ae-73b78d4a75e61854b06bc33af78fd93780a438a5.tar.gz
master-31e0f0ae-73b78d4a75e61854b06bc33af78fd93780a438a5.tar.bz2
master-31e0f0ae-73b78d4a75e61854b06bc33af78fd93780a438a5.zip
only build bin packages for the selected build variants (same behaviour as with ipkg builds)
SVN-Revision: 21455
Diffstat (limited to 'include/package-bin.mk')
-rw-r--r--include/package-bin.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/package-bin.mk b/include/package-bin.mk
index 6ee7aed621..96c1aeffcf 100644
--- a/include/package-bin.mk
+++ b/include/package-bin.mk
@@ -7,6 +7,7 @@
ifeq ($(DUMP),)
define BuildTarget/bin
+ ifeq ($(if $(VARIANT),$(BUILD_VARIANT)),$(VARIANT))
ifdef Package/$(1)/install
ifneq ($(CONFIG_PACKAGE_$(1))$(SDK)$(DEVELOPER),)
compile: install-bin-$(1)
@@ -16,6 +17,7 @@ ifeq ($(DUMP),)
@echo "WARNING: skipping $(1) -- package not selected"
endif
endif
+ endif
install-bin-$(1): $(STAMP_BUILT)
rm -rf $(BIN_DIR)/$(1)