summaryrefslogtreecommitdiffstats
path: root/include/netfilter.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-03-12 02:07:22 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-03-12 02:07:22 +0000
commite6af9d374aeea2718aaa3bbc86ed516cdd2df4d9 (patch)
tree5b85b8292d56acf50028c086c652635af7918afc /include/netfilter.mk
parent2dedd94d66507b8a60f7ac689f0f91eb4cacb7ed (diff)
downloadmaster-31e0f0ae-e6af9d374aeea2718aaa3bbc86ed516cdd2df4d9.tar.gz
master-31e0f0ae-e6af9d374aeea2718aaa3bbc86ed516cdd2df4d9.tar.bz2
master-31e0f0ae-e6af9d374aeea2718aaa3bbc86ed516cdd2df4d9.zip
fix ipt_ttl and ipt_TTL userspace library packaging
SVN-Revision: 30897
Diffstat (limited to 'include/netfilter.mk')
-rw-r--r--include/netfilter.mk8
1 files changed, 4 insertions, 4 deletions
diff --git a/include/netfilter.mk b/include/netfilter.mk
index 1cbb9a8b86..1a044edb15 100644
--- a/include/netfilter.mk
+++ b/include/netfilter.mk
@@ -150,11 +150,11 @@ else
endif
# userland only
-$(eval $(if $(NF_KMOD),,$(call nf_add,IPT_IPOPT,CONFIG_NETFILTER_XT_MATCH_DSCP, $(P_XT)xt_tos)))
-$(eval $(if $(NF_KMOD),,$(call nf_add,IPT_IPOPT,CONFIG_NETFILTER_XT_TARGET_DSCP, $(P_XT)xt_TOS)))
+$(eval $(if $(NF_KMOD),,$(call nf_add,IPT_IPOPT,CONFIG_NETFILTER_XT_MATCH_DSCP, xt_tos)))
+$(eval $(if $(NF_KMOD),,$(call nf_add,IPT_IPOPT,CONFIG_NETFILTER_XT_TARGET_DSCP, xt_TOS)))
+$(eval $(if $(NF_KMOD),,$(call nf_add,IPT_IPOPT,CONFIG_NETFILTER_XT_TARGET_HL, ipt_ttl)))
+$(eval $(if $(NF_KMOD),,$(call nf_add,IPT_IPOPT,CONFIG_NETFILTER_XT_TARGET_HL, ipt_TTL)))
-$(eval $(if $(NF_KMOD),,$(call nf_add,IPT_IPOPT,CONFIG_IP_NF_MATCH_TTL, ipt_ttl)))
-$(eval $(if $(NF_KMOD),,$(call nf_add,IPT_IPOPT,CONFIG_IP_NF_TARGET_TTL, ipt_TTL)))
$(eval $(call nf_add,IPT_IPOPT,CONFIG_NETFILTER_XT_MATCH_HL, $(P_XT)xt_hl))
$(eval $(call nf_add,IPT_IPOPT,CONFIG_NETFILTER_XT_TARGET_HL, $(P_XT)xt_HL))