summaryrefslogtreecommitdiffstats
path: root/include/netfilter.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-12-13 18:33:11 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-12-13 18:33:11 +0000
commitc0f4c9e0d82e7b8be4b81eaa9107517a9d9c9702 (patch)
tree410b2ea5e8b589fd67b9ca5d989b3c82382b55a4 /include/netfilter.mk
parent6b87e0706da40d70254b07f857e69265630ef26e (diff)
downloadmaster-31e0f0ae-c0f4c9e0d82e7b8be4b81eaa9107517a9d9c9702.tar.gz
master-31e0f0ae-c0f4c9e0d82e7b8be4b81eaa9107517a9d9c9702.tar.bz2
master-31e0f0ae-c0f4c9e0d82e7b8be4b81eaa9107517a9d9c9702.zip
include/netfilter.mk: fix kmod-ipt-tee build with 4.3/4.4
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 47890
Diffstat (limited to 'include/netfilter.mk')
-rw-r--r--include/netfilter.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/netfilter.mk b/include/netfilter.mk
index 68af50b1df..c8e6a8b239 100644
--- a/include/netfilter.mk
+++ b/include/netfilter.mk
@@ -255,6 +255,8 @@ $(eval $(call nf_add,IPT_LED,CONFIG_NETFILTER_XT_TARGET_LED, $(P_XT)xt_LED))
# tee
$(eval $(call nf_add,IPT_TEE,CONFIG_NETFILTER_XT_TARGET_TEE, $(P_XT)xt_TEE))
+$(eval $(if $(NF_KMOD),$(call nf_add,IPT_TEE,CONFIG_NF_DUP_IPV4, $(P_V4)nf_dup_ipv4, ge 4.3),))
+$(eval $(if $(NF_KMOD),$(call nf_add,IPT_TEE,CONFIG_NF_DUP_IPV6, $(P_V6)nf_dup_ipv6, ge 4.3),))
# u32