summaryrefslogtreecommitdiffstats
path: root/include/netfilter.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2012-12-22 10:17:29 +0000
committerJohn Crispin <john@openwrt.org>2012-12-22 10:17:29 +0000
commitb21458709a78eccd8c072a9af5d6f37e23a5eab2 (patch)
tree79cca9ccbd39eda97a2d1d429e34e327c9cf0864 /include/netfilter.mk
parentefe3225e2b070c26f773b3441c9bfa788b76532a (diff)
downloadmaster-31e0f0ae-b21458709a78eccd8c072a9af5d6f37e23a5eab2.tar.gz
master-31e0f0ae-b21458709a78eccd8c072a9af5d6f37e23a5eab2.tar.bz2
master-31e0f0ae-b21458709a78eccd8c072a9af5d6f37e23a5eab2.zip
fix ipv4 nat on 3.7 by adding missing iptables modules
SVN-Revision: 34841
Diffstat (limited to 'include/netfilter.mk')
-rw-r--r--include/netfilter.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/netfilter.mk b/include/netfilter.mk
index 20bfffece0..12c5f9fff1 100644
--- a/include/netfilter.mk
+++ b/include/netfilter.mk
@@ -159,7 +159,7 @@ $(eval $(call nf_add,IPT_IPV6,CONFIG_IP6_NF_TARGET_REJECT, $(P_V6)ip6t_REJECT))
# nat
# kernel only
-$(eval $(if $(NF_KMOD),$(call nf_add,IPT_NAT,CONFIG_NF_NAT, $(P_XT)nf_nat $(P_V4)iptable_nat, ge 3.7.0),))
+$(eval $(if $(NF_KMOD),$(call nf_add,IPT_NAT,CONFIG_NF_NAT, $(P_XT)nf_nat $(P_V4)nf_nat_ipv4 $(P_XT)xt_nat $(P_V4)iptable_nat, ge 3.7.0),))
$(eval $(if $(NF_KMOD),$(call nf_add,IPT_NAT,CONFIG_NF_NAT, $(P_V4)nf_nat $(P_V4)iptable_nat, lt 3.7.0),))
# userland only