summaryrefslogtreecommitdiffstats
path: root/include/netfilter.mk
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2012-11-18 18:52:38 +0000
committerImre Kaloz <kaloz@openwrt.org>2012-11-18 18:52:38 +0000
commit935ca3f3eb7435b50b91bc2ed341a4bbd6e759b0 (patch)
tree48e34d859046c692a221dddd165db5abc37feb90 /include/netfilter.mk
parentd0226aff1d62d39530819938ac116ee3cbb93efa (diff)
downloadmaster-31e0f0ae-935ca3f3eb7435b50b91bc2ed341a4bbd6e759b0.tar.gz
master-31e0f0ae-935ca3f3eb7435b50b91bc2ed341a4bbd6e759b0.tar.bz2
master-31e0f0ae-935ca3f3eb7435b50b91bc2ed341a4bbd6e759b0.zip
add 3.7-rc6 support (patch 820 still has to be fixed)
SVN-Revision: 34247
Diffstat (limited to 'include/netfilter.mk')
-rw-r--r--include/netfilter.mk15
1 files changed, 12 insertions, 3 deletions
diff --git a/include/netfilter.mk b/include/netfilter.mk
index e42b50584b..7f0078d76f 100644
--- a/include/netfilter.mk
+++ b/include/netfilter.mk
@@ -152,7 +152,11 @@ $(eval $(call nf_add,IPT_IPV6,CONFIG_IP6_NF_TARGET_REJECT, $(P_V6)ip6t_REJECT))
# nat
# kernel only
-$(eval $(if $(NF_KMOD),$(call nf_add,IPT_NAT,CONFIG_NF_NAT, $(P_V4)nf_nat $(P_V4)iptable_nat),))
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.7.0)),1)
+ $(eval $(if $(NF_KMOD),$(call nf_add,IPT_NAT,CONFIG_NF_NAT, $(P_XT)nf_nat $(P_V4)iptable_nat),))
+else
+ $(eval $(if $(NF_KMOD),$(call nf_add,IPT_NAT,CONFIG_NF_NAT, $(P_V4)nf_nat $(P_V4)iptable_nat),))
+endif
# userland only
$(eval $(if $(NF_KMOD),,$(call nf_add,IPT_NAT,CONFIG_NF_NAT, ipt_SNAT ipt_DNAT)))
@@ -170,9 +174,14 @@ $(eval $(call nf_add,IPT_NAT_EXTRA,CONFIG_IP_NF_TARGET_REDIRECT, $(P_V4)ipt_REDI
$(eval $(call nf_add,IPT_NATHELPER,CONFIG_IP_NF_NAT_FTP, $(P_V4)ip_nat_ftp))
$(eval $(call nf_add,IPT_NATHELPER,CONFIG_NF_CONNTRACK_FTP, $(P_XT)nf_conntrack_ftp))
-$(eval $(call nf_add,IPT_NATHELPER,CONFIG_NF_NAT_FTP, $(P_V4)nf_nat_ftp))
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.7.0)),1)
+ $(eval $(call nf_add,IPT_NATHELPER,CONFIG_NF_NAT_FTP, $(P_XT)nf_nat_ftp))
+ $(eval $(call nf_add,IPT_NATHELPER,CONFIG_NF_NAT_IRC, $(P_XT)nf_nat_irc))
+else
+ $(eval $(call nf_add,IPT_NATHELPER,CONFIG_NF_NAT_FTP, $(P_V4)nf_nat_ftp))
+ $(eval $(call nf_add,IPT_NATHELPER,CONFIG_NF_NAT_IRC, $(P_V4)nf_nat_irc))
+endif
$(eval $(call nf_add,IPT_NATHELPER,CONFIG_NF_CONNTRACK_IRC, $(P_XT)nf_conntrack_irc))
-$(eval $(call nf_add,IPT_NATHELPER,CONFIG_NF_NAT_IRC, $(P_V4)nf_nat_irc))
# nathelper-extra