summaryrefslogtreecommitdiffstats
path: root/include/netfilter.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-12-11 09:53:50 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-12-11 09:53:50 +0000
commit842078340713cabd375409ca4424cb154526ac4c (patch)
treefac86bd00df9464f009de339ad61c70f2d9d7631 /include/netfilter.mk
parent51f59a4f53edfbf802b263260e50f736d7a70630 (diff)
downloadmaster-31e0f0ae-842078340713cabd375409ca4424cb154526ac4c.tar.gz
master-31e0f0ae-842078340713cabd375409ca4424cb154526ac4c.tar.bz2
master-31e0f0ae-842078340713cabd375409ca4424cb154526ac4c.zip
netfilter.mk: fix packaging of xt_LOG.ko, it moved between 3.3.8 and 3.6.x
SVN-Revision: 34625
Diffstat (limited to 'include/netfilter.mk')
-rw-r--r--include/netfilter.mk8
1 files changed, 6 insertions, 2 deletions
diff --git a/include/netfilter.mk b/include/netfilter.mk
index ef38d50ad8..76dea6f67d 100644
--- a/include/netfilter.mk
+++ b/include/netfilter.mk
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -37,7 +37,11 @@ $(eval $(call nf_add,IPT_CORE,CONFIG_NETFILTER_XT_MATCH_MAC, $(P_XT)xt_mac))
$(eval $(call nf_add,IPT_CORE,CONFIG_NETFILTER_XT_MATCH_MULTIPORT, $(P_XT)xt_multiport))
$(eval $(call nf_add,IPT_CORE,CONFIG_NETFILTER_XT_MATCH_COMMENT, $(P_XT)xt_comment))
-$(eval $(call nf_add,IPT_CORE,CONFIG_IP_NF_TARGET_LOG, $(P_V4)ipt_LOG))
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.4.0)),1)
+ $(eval $(call nf_add,IPT_CORE,CONFIG_NETFILTER_XT_TARGET_LOG, $(P_XT)xt_LOG))
+else
+ $(eval $(call nf_add,IPT_CORE,CONFIG_IP_NF_TARGET_LOG, $(P_V4)ipt_LOG))
+endif
$(eval $(call nf_add,IPT_CORE,CONFIG_NETFILTER_XT_TARGET_TCPMSS, $(P_XT)xt_TCPMSS))
$(eval $(call nf_add,IPT_CORE,CONFIG_IP_NF_TARGET_REJECT, $(P_V4)ipt_REJECT))