summaryrefslogtreecommitdiffstats
path: root/include/netfilter.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-11-19 14:09:01 +0000
committerJohn Crispin <john@openwrt.org>2014-11-19 14:09:01 +0000
commit6521f53c653fcea9ca9b7d0f338a2afc5e4c5946 (patch)
treedef5dc8dd818272d9fe0e3afdea641aaea038a08 /include/netfilter.mk
parentd265ebd1dcd5a9cbf793b572caea1c7d3bcb3692 (diff)
downloadmaster-31e0f0ae-6521f53c653fcea9ca9b7d0f338a2afc5e4c5946.tar.gz
master-31e0f0ae-6521f53c653fcea9ca9b7d0f338a2afc5e4c5946.tar.bz2
master-31e0f0ae-6521f53c653fcea9ca9b7d0f338a2afc5e4c5946.zip
keernel: Fixed dependencies in netfilter modules introduced with 3.18 kernel
Building current trunk with 3.18 kernel fired some errors like 'missed dependancy of module XXX from library kmod_YYY.ko'. These patch fixes 3 of such issues which are critical to have a successful build. Signed-off-by: Alexey N Vinogradov <a.n.vinogradov@gmail.com> SVN-Revision: 43318
Diffstat (limited to 'include/netfilter.mk')
-rw-r--r--include/netfilter.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/include/netfilter.mk b/include/netfilter.mk
index efef04a2f6..ead32cb183 100644
--- a/include/netfilter.mk
+++ b/include/netfilter.mk
@@ -53,6 +53,7 @@ $(eval $(call nf_add,IPT_CORE,CONFIG_NETFILTER_XT_TARGET_LOG, $(P_XT)xt_LOG, ge
$(eval $(call nf_add,IPT_CORE,CONFIG_IP_NF_TARGET_LOG, $(P_V4)ipt_LOG, lt 3.4.0))
$(eval $(call nf_add,IPT_CORE,CONFIG_NETFILTER_XT_TARGET_TCPMSS, $(P_XT)xt_TCPMSS))
$(eval $(call nf_add,IPT_CORE,CONFIG_IP_NF_TARGET_REJECT, $(P_V4)ipt_REJECT))
+$(eval $(call nf_add,IPT_CORE,CONFIG_IP_NF_TARGET_REJECT, $(P_V4)nf_reject_ipv4, ge 3.18.0))
$(eval $(call nf_add,IPT_CORE,CONFIG_NETFILTER_XT_MATCH_TIME, $(P_XT)xt_time))
$(eval $(call nf_add,IPT_CORE,CONFIG_NETFILTER_XT_MARK, $(P_XT)xt_mark))
@@ -156,6 +157,7 @@ $(eval $(if $(NF_KMOD),,$(call nf_add,IPT_IPV6,CONFIG_IP6_NF_IPTABLES, ip6t_icmp
$(eval $(call nf_add,IPT_IPV6,CONFIG_IP6_NF_TARGET_LOG, $(P_V6)ip6t_LOG))
$(eval $(call nf_add,IPT_IPV6,CONFIG_IP6_NF_TARGET_REJECT, $(P_V6)ip6t_REJECT))
+$(eval $(call nf_add,IPT_IPV6,CONFIG_IP6_NF_TARGET_REJECT, $(P_V6)nf_reject_ipv6, ge 3.18.0))
# ipv6 extra
$(eval $(call nf_add,IPT_IPV6_EXTRA,CONFIG_IP6_NF_MATCH_IPV6HEADER, $(P_V6)ip6t_ipv6header))
@@ -188,6 +190,7 @@ $(eval $(if $(NF_KMOD),,$(call nf_add,IPT_NAT,CONFIG_NF_NAT, ipt_SNAT ipt_DNAT))
$(eval $(if $(NF_KMOD),,$(call nf_add,IPT_NAT6,CONFIG_IP6_NF_TARGET_NPT, ip6t_DNPT ip6t_SNPT)))
$(eval $(call nf_add,IPT_NAT,CONFIG_IP_NF_TARGET_MASQUERADE, $(P_V4)ipt_MASQUERADE))
+$(eval $(call nf_add,IPT_NAT,CONFIG_IP_NF_TARGET_MASQUERADE, $(P_V4)nf_nat_masquerade_ipv4, ge 3.18.0))
$(eval $(call nf_add,IPT_NAT,CONFIG_IP_NF_TARGET_REDIRECT, $(P_XT)xt_REDIRECT, ge 3.7.0))
$(eval $(call nf_add,IPT_NAT,CONFIG_IP_NF_TARGET_REDIRECT, $(P_V4)ipt_REDIRECT, lt 3.7.0))