summaryrefslogtreecommitdiffstats
path: root/include/netfilter.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-04-09 19:42:52 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-04-09 19:42:52 +0000
commite744c3130a8fde8bbc04e7071a004b33e70e39e7 (patch)
treec0596b63dbad8b3df98fb1b3646a94883583a6bd /include/netfilter.mk
parent4dd7a65697af641f080c07b21cee1a56999d112f (diff)
downloadmaster-31e0f0ae-e744c3130a8fde8bbc04e7071a004b33e70e39e7.tar.gz
master-31e0f0ae-e744c3130a8fde8bbc04e7071a004b33e70e39e7.tar.bz2
master-31e0f0ae-e744c3130a8fde8bbc04e7071a004b33e70e39e7.zip
move iptable_raw to the conntrack-extra package
SVN-Revision: 15175
Diffstat (limited to 'include/netfilter.mk')
-rw-r--r--include/netfilter.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/netfilter.mk b/include/netfilter.mk
index fb1dc334a4..87deb277a7 100644
--- a/include/netfilter.mk
+++ b/include/netfilter.mk
@@ -70,6 +70,7 @@ $(eval $(call nf_add,IPT_CONNTRACK_EXTRA,CONFIG_NETFILTER_XT_MATCH_HELPER, $(P_X
$(eval $(call nf_add,IPT_CONNTRACK_EXTRA,CONFIG_IP_NF_MATCH_RECENT, $(P_V4)ipt_recent))
$(eval $(call nf_add,IPT_CONNTRACK_EXTRA,CONFIG_NETFILTER_XT_MATCH_RECENT, $(P_XT)xt_recent))
+$(eval $(call nf_add,IPT_CONNTRACK_EXTRA,CONFIG_IP_NF_RAW, $(P_V4)iptable_raw))
$(eval $(call nf_add,IPT_CONNTRACK_EXTRA,CONFIG_IP_NF_TARGET_CONNMARK, $(P_V4)ipt_CONNMARK))
$(eval $(call nf_add,IPT_CONNTRACK_EXTRA,CONFIG_NETFILTER_XT_TARGET_CONNMARK, $(P_XT)xt_CONNMARK))
$(eval $(call nf_add,IPT_CONNTRACK_EXTRA,CONFIG_NETFILTER_XT_TARGET_NOTRACK, $(P_XT)xt_NOTRACK))
@@ -78,7 +79,6 @@ $(eval $(call nf_add,IPT_CONNTRACK_EXTRA,CONFIG_NETFILTER_XT_TARGET_NOTRACK, $(P
# extra
# kernel only
-$(eval $(if $(NF_KMOD),$(call nf_add,IPT_EXTRA,CONFIG_IP_NF_RAW, $(P_V4)iptable_raw),))
$(eval $(call nf_add,IPT_EXTRA,CONFIG_IP_NF_MATCH_CONDITION, $(P_V4)ipt_condition))
$(eval $(call nf_add,IPT_EXTRA,CONFIG_IP_NF_MATCH_OWNER, $(P_V4)ipt_owner))