summaryrefslogtreecommitdiffstats
path: root/include/netfilter.mk
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-04-15 06:11:23 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-04-15 06:11:23 +0000
commitd80f43d15f4e1fb9c8c45fdafc7f0c8838573047 (patch)
treea2f4cbd0b328b674326665e96c88fd493ef8dc00 /include/netfilter.mk
parentece27874c17a3f84bae9af15399c0d92beb2620e (diff)
downloadmaster-31e0f0ae-d80f43d15f4e1fb9c8c45fdafc7f0c8838573047.tar.gz
master-31e0f0ae-d80f43d15f4e1fb9c8c45fdafc7f0c8838573047.tar.bz2
master-31e0f0ae-d80f43d15f4e1fb9c8c45fdafc7f0c8838573047.zip
update iptables to 1.4.0 (2.6 kernels only), refresh kernel patches
SVN-Revision: 10843
Diffstat (limited to 'include/netfilter.mk')
-rw-r--r--include/netfilter.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/include/netfilter.mk b/include/netfilter.mk
index ee0dbf3a13..7e7005d2a2 100644
--- a/include/netfilter.mk
+++ b/include/netfilter.mk
@@ -100,6 +100,7 @@ $(eval $(call nf_add,IPT_IPOPT,CONFIG_NETFILTER_XT_MATCH_STATISTIC, $(P_XT)xt_st
$(eval $(call nf_add,IPT_IPOPT,CONFIG_IP_NF_MATCH_TCPMSS, $(P_V4)ipt_tcpmss))
$(eval $(call nf_add,IPT_IPOPT,CONFIG_NETFILTER_XT_MATCH_TCPMSS, $(P_XT)xt_tcpmss))
$(eval $(call nf_add,IPT_IPOPT,CONFIG_IP_NF_MATCH_TIME, $(P_V4)ipt_time))
+$(eval $(call nf_add,IPT_IPOPT,CONFIG_NETFILTER_XT_MATCH_TIME, $(P_XT)xt_time))
$(eval $(call nf_add,IPT_IPOPT,CONFIG_IP_NF_MATCH_TOS, $(P_V4)ipt_tos))
$(eval $(call nf_add,IPT_IPOPT,CONFIG_IP_NF_MATCH_TTL, $(P_V4)ipt_ttl))
$(eval $(call nf_add,IPT_IPOPT,CONFIG_IP_NF_MATCH_UNCLEAN, $(P_V4)ipt_unclean))
@@ -249,6 +250,9 @@ $(eval $(call nf_add,IPT_ULOG,CONFIG_IP_NF_TARGET_ULOG, $(P_V4)ipt_ULOG))
IPT_BUILTIN := $(if $(NF_KMOD),,$(P_V4)ipt_standard)
IPT_BUILTIN += $(if $(NF_KMOD),,$(P_V4)ipt_icmp $(P_V4)ipt_tcp $(P_V4)ipt_udp)
+IPT_BUILTIN += $(if $(NF_KMOD),,$(P_XT)xt_standard)
+IPT_BUILTIN += $(if $(NF_KMOD),,$(P_XT)xt_icmp $(P_XT)xt_tcp $(P_XT)xt_udp)
+
IPT_BUILTIN += $(IPT_CONNTRACK-y)
IPT_BUILTIN += $(IPT_EXTRA-y)
IPT_BUILTIN += $(IPT_FILTER-y)