summaryrefslogtreecommitdiffstats
path: root/include/netfilter.mk
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-12-10 16:00:04 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-12-10 16:00:04 +0000
commita7cac1dc31e1472fe5109a65f03fd4ed9d79915d (patch)
tree289d370f2cb204cc09ccabc435f06e989f27cdab /include/netfilter.mk
parentb74b6d3e96c3b622db696791def42b997e7f38d2 (diff)
downloadmaster-31e0f0ae-a7cac1dc31e1472fe5109a65f03fd4ed9d79915d.tar.gz
master-31e0f0ae-a7cac1dc31e1472fe5109a65f03fd4ed9d79915d.tar.bz2
master-31e0f0ae-a7cac1dc31e1472fe5109a65f03fd4ed9d79915d.zip
fix conntrack on 2.6.28
SVN-Revision: 13582
Diffstat (limited to 'include/netfilter.mk')
-rw-r--r--include/netfilter.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/netfilter.mk b/include/netfilter.mk
index 8acff9048f..76d95f47b9 100644
--- a/include/netfilter.mk
+++ b/include/netfilter.mk
@@ -51,6 +51,7 @@ $(eval $(call nf_add,IPT_CORE,CONFIG_IP_NF_TARGET_REJECT, $(P_V4)ipt_REJECT))
$(eval $(if $(NF_KMOD),$(call nf_add,IPT_CONNTRACK,CONFIG_NF_CONNTRACK, $(P_XT)nf_conntrack),))
$(eval $(if $(NF_KMOD),$(call nf_add,IPT_CONNTRACK,CONFIG_IP_NF_CONNTRACK, $(P_V4)ip_conntrack),))
$(eval $(if $(NF_KMOD),$(call nf_add,IPT_CONNTRACK,CONFIG_NF_CONNTRACK_IPV4, $(P_V4)nf_conntrack_ipv4),))
+$(eval $(if $(NF_KMOD),$(call nf_add,IPT_CONNTRACK,CONFIG_NF_DEFRAG_IPV4, $(P_V4)nf_defrag_ipv4),))
$(eval $(call nf_add,IPT_CONNTRACK,CONFIG_IP_NF_MATCH_STATE, $(P_V4)ipt_state))
$(eval $(call nf_add,IPT_CONNTRACK,CONFIG_NETFILTER_XT_MATCH_STATE, $(P_XT)xt_state))