summaryrefslogtreecommitdiffstats
path: root/include/netfilter.mk
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2007-10-07 17:17:04 +0000
committerGabor Juhos <juhosg@openwrt.org>2007-10-07 17:17:04 +0000
commit8309e3dff2170afcbacb5b0b14a9d2b06f6cca8b (patch)
treeb79031553b8f3cb5c79e1fb415f7b5dc8e2466c8 /include/netfilter.mk
parentab72460ac6522ad7ec6998d82dbd246ac9205f72 (diff)
downloadmaster-31e0f0ae-8309e3dff2170afcbacb5b0b14a9d2b06f6cca8b.tar.gz
master-31e0f0ae-8309e3dff2170afcbacb5b0b14a9d2b06f6cca8b.tar.bz2
master-31e0f0ae-8309e3dff2170afcbacb5b0b14a9d2b06f6cca8b.zip
add TARPIT support to netfilter/iptables * netfilter: add the xt_TARPIT target module required by xt_CHAOS * include/netfilter.mk: reorder, xt_CHAOS depends on xt_TARPIT and xt_DELUDE * iptables: add libipt_TARPIT to the kmod-ipt-extra package, bump release number * original patchset can be found [http://tinyurl.com/2mjk2kx here]
SVN-Revision: 9178
Diffstat (limited to 'include/netfilter.mk')
-rw-r--r--include/netfilter.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/include/netfilter.mk b/include/netfilter.mk
index 9ed736aea7..bb59bf03d8 100644
--- a/include/netfilter.mk
+++ b/include/netfilter.mk
@@ -1,4 +1,4 @@
-#
+#
# Copyright (C) 2006 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
@@ -60,8 +60,9 @@ $(eval $(call nf_add,IPT_EXTRA,CONFIG_NETFILTER_XT_MATCH_PORTSCAN, $(P_XT)xt_por
#$(eval $(call nf_add,IPT_EXTRA,CONFIG_IP_NF_MATCH_QUOTA, $(P_V4)ipt_quota))
$(eval $(call nf_add,IPT_EXTRA,CONFIG_NETFILTER_XT_MATCH_QUOTA, $(P_XT)xt_quota))
-$(eval $(call nf_add,IPT_EXTRA,CONFIG_NETFILTER_XT_TARGET_CHAOS, $(P_XT)xt_CHAOS))
+$(eval $(call nf_add,IPT_EXTRA,CONFIG_NETFILTER_XT_TARGET_TARPIT, $(P_XT)xt_TARPIT))
$(eval $(call nf_add,IPT_EXTRA,CONFIG_NETFILTER_XT_TARGET_DELUDE, $(P_XT)xt_DELUDE))
+$(eval $(call nf_add,IPT_EXTRA,CONFIG_NETFILTER_XT_TARGET_CHAOS, $(P_XT)xt_CHAOS))
$(eval $(call nf_add,IPT_EXTRA,CONFIG_IP_NF_TARGET_LOG, $(P_V4)ipt_LOG))
$(eval $(call nf_add,IPT_EXTRA,CONFIG_IP_NF_TARGET_REJECT, $(P_V4)ipt_REJECT))
#$(eval $(call nf_add,IPT_EXTRA,CONFIG_IP_NF_TARGET_ROUTE, $(P_V4)ipt_ROUTE))