summaryrefslogtreecommitdiffstats
path: root/include/netfilter.mk
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2009-05-14 19:01:38 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2009-05-14 19:01:38 +0000
commit73cfaa0f2b495f93eea9e2e93c3f3ca0529cf99e (patch)
treecd58a380513a1b4f46c32e5a4b030416fd9e2e99 /include/netfilter.mk
parentf9532a06b17d38f86e116b2ef57629ebe4b5d12d (diff)
downloadmaster-31e0f0ae-73cfaa0f2b495f93eea9e2e93c3f3ca0529cf99e.tar.gz
master-31e0f0ae-73cfaa0f2b495f93eea9e2e93c3f3ca0529cf99e.tar.bz2
master-31e0f0ae-73cfaa0f2b495f93eea9e2e93c3f3ca0529cf99e.zip
ipt_TTL and ipt_ttl moved and were renamed in kernel 2.6.30
SVN-Revision: 15851
Diffstat (limited to 'include/netfilter.mk')
-rw-r--r--include/netfilter.mk10
1 files changed, 8 insertions, 2 deletions
diff --git a/include/netfilter.mk b/include/netfilter.mk
index 7df9baea13..079efb0fb2 100644
--- a/include/netfilter.mk
+++ b/include/netfilter.mk
@@ -119,7 +119,6 @@ $(eval $(call nf_add,IPT_IPOPT,CONFIG_IP_NF_MATCH_TCPMSS, $(P_V4)ipt_tcpmss))
$(eval $(call nf_add,IPT_IPOPT,CONFIG_NETFILTER_XT_MATCH_TCPMSS, $(P_XT)xt_tcpmss))
$(eval $(call nf_add,IPT_IPOPT,CONFIG_IP_NF_MATCH_TIME, $(P_V4)ipt_time))
$(eval $(call nf_add,IPT_IPOPT,CONFIG_NETFILTER_XT_MATCH_TIME, $(P_XT)xt_time))
-$(eval $(call nf_add,IPT_IPOPT,CONFIG_IP_NF_MATCH_TTL, $(P_V4)ipt_ttl))
$(eval $(call nf_add,IPT_IPOPT,CONFIG_IP_NF_MATCH_UNCLEAN, $(P_V4)ipt_unclean))
$(eval $(call nf_add,IPT_IPOPT,CONFIG_IP_NF_TARGET_CLASSIFY, $(P_V4)ipt_CLASSIFY ))
@@ -128,7 +127,6 @@ $(eval $(call nf_add,IPT_IPOPT,CONFIG_IP_NF_TARGET_DSCP, $(P_V4)ipt_DSCP))
$(eval $(call nf_add,IPT_IPOPT,CONFIG_IP_NF_TARGET_ECN, $(P_V4)ipt_ECN))
$(eval $(call nf_add,IPT_IPOPT,CONFIG_IP_NF_TARGET_MARK, $(P_V4)ipt_MARK))
$(eval $(call nf_add,IPT_IPOPT,CONFIG_NETFILTER_XT_TARGET_MARK, $(P_XT)xt_MARK))
-$(eval $(call nf_add,IPT_IPOPT,CONFIG_IP_NF_TARGET_TTL, $(P_V4)ipt_TTL))
# XXX: tos/TOS extensions have been merged in dscp/DSCP in linux 2.6.25, but not yet in iptables
ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.25)),1)
@@ -140,6 +138,14 @@ else
$(eval $(call nf_add,IPT_IPOPT,CONFIG_IP_NF_TARGET_TOS, $(P_V4)ipt_TOS))
endif
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.30)),1)
+ $(eval $(call nf_add,IPT_IPOPT,CONFIG_NETFILTER_XT_MATCH_HL, $(P_XT)xt_hl))
+ $(eval $(call nf_add,IPT_IPOPT,CONFIG_NETFILTER_XT_TARGET_HL, $(P_XT)xt_HL))
+else
+ $(eval $(call nf_add,IPT_IPOPT,CONFIG_IP_NF_MATCH_TTL, $(P_V4)ipt_ttl))
+ $(eval $(call nf_add,IPT_IPOPT,CONFIG_IP_NF_TARGET_TTL, $(P_V4)ipt_TTL))
+endif
+
# iprange