summaryrefslogtreecommitdiffstats
path: root/include/netfilter.mk
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2007-10-12 14:58:35 +0000
committerGabor Juhos <juhosg@openwrt.org>2007-10-12 14:58:35 +0000
commit4e05416c393eb799a98dc8a03e5857e45579dd64 (patch)
treec688466c8e05ccc6eaa598014fa06020e5bc976f /include/netfilter.mk
parent4bc640743a56ddad268e8d74807c6b6b9fc42956 (diff)
downloadmaster-31e0f0ae-4e05416c393eb799a98dc8a03e5857e45579dd64.tar.gz
master-31e0f0ae-4e05416c393eb799a98dc8a03e5857e45579dd64.tar.bz2
master-31e0f0ae-4e05416c393eb799a98dc8a03e5857e45579dd64.zip
netfilter/ipset cleanups * rename patches to follow our naming conventions * update ipset patches with revision 7096 of [https://svn.netfilter.org/netfilter/trunk/patch-o-matic-ng pom] * add CONFIG_IP_NF_SET_IPTREEMAP to default kernel configs * add ip_set_iptreemap to include/netfilter.mk * update kmod-ipt-ipset module description
SVN-Revision: 9269
Diffstat (limited to 'include/netfilter.mk')
-rw-r--r--include/netfilter.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/netfilter.mk b/include/netfilter.mk
index bb59bf03d8..0a0e54af16 100644
--- a/include/netfilter.mk
+++ b/include/netfilter.mk
@@ -135,6 +135,7 @@ $(eval $(call nf_add,IPT_IPSET,CONFIG_IP_NF_SET_IPHASH, $(P_V4)ip_set_iphash))
$(eval $(call nf_add,IPT_IPSET,CONFIG_IP_NF_SET_IPMAP, $(P_V4)ip_set_ipmap))
$(eval $(call nf_add,IPT_IPSET,CONFIG_IP_NF_SET_IPPORTHASH, $(P_V4)ip_set_ipporthash))
$(eval $(call nf_add,IPT_IPSET,CONFIG_IP_NF_SET_IPTREE, $(P_V4)ip_set_iptree))
+$(eval $(call nf_add,IPT_IPSET,CONFIG_IP_NF_SET_IPTREEMAP, $(P_V4)ip_set_iptreemap))
$(eval $(call nf_add,IPT_IPSET,CONFIG_IP_NF_SET_MACIPMAP, $(P_V4)ip_set_macipmap))
$(eval $(call nf_add,IPT_IPSET,CONFIG_IP_NF_SET_NETHASH, $(P_V4)ip_set_nethash))
$(eval $(call nf_add,IPT_IPSET,CONFIG_IP_NF_SET_PORTMAP, $(P_V4)ip_set_portmap))