summaryrefslogtreecommitdiffstats
path: root/include/netfilter.mk
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-12-10 18:44:46 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-12-10 18:44:46 +0000
commit24e299f95d1839a794a8475c876c6c5b5064b975 (patch)
tree45787b08d7c521cf3f2684543f8ad82d9956ad1e /include/netfilter.mk
parentfe2af46117635c9a17c809b0bab9671fad5ea95c (diff)
downloadmaster-31e0f0ae-24e299f95d1839a794a8475c876c6c5b5064b975.tar.gz
master-31e0f0ae-24e299f95d1839a794a8475c876c6c5b5064b975.tar.bz2
master-31e0f0ae-24e299f95d1839a794a8475c876c6c5b5064b975.zip
defrag needs to be loaded before conntrack_ipv4
SVN-Revision: 13585
Diffstat (limited to 'include/netfilter.mk')
-rw-r--r--include/netfilter.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/netfilter.mk b/include/netfilter.mk
index 76d95f47b9..6968feffd3 100644
--- a/include/netfilter.mk
+++ b/include/netfilter.mk
@@ -50,8 +50,8 @@ $(eval $(call nf_add,IPT_CORE,CONFIG_IP_NF_TARGET_REJECT, $(P_V4)ipt_REJECT))
# kernel only
$(eval $(if $(NF_KMOD),$(call nf_add,IPT_CONNTRACK,CONFIG_NF_CONNTRACK, $(P_XT)nf_conntrack),))
$(eval $(if $(NF_KMOD),$(call nf_add,IPT_CONNTRACK,CONFIG_IP_NF_CONNTRACK, $(P_V4)ip_conntrack),))
-$(eval $(if $(NF_KMOD),$(call nf_add,IPT_CONNTRACK,CONFIG_NF_CONNTRACK_IPV4, $(P_V4)nf_conntrack_ipv4),))
$(eval $(if $(NF_KMOD),$(call nf_add,IPT_CONNTRACK,CONFIG_NF_DEFRAG_IPV4, $(P_V4)nf_defrag_ipv4),))
+$(eval $(if $(NF_KMOD),$(call nf_add,IPT_CONNTRACK,CONFIG_NF_CONNTRACK_IPV4, $(P_V4)nf_conntrack_ipv4),))
$(eval $(call nf_add,IPT_CONNTRACK,CONFIG_IP_NF_MATCH_STATE, $(P_V4)ipt_state))
$(eval $(call nf_add,IPT_CONNTRACK,CONFIG_NETFILTER_XT_MATCH_STATE, $(P_XT)xt_state))