summaryrefslogtreecommitdiffstats
path: root/include/netfilter.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-05-14 21:46:33 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-05-14 21:46:33 +0000
commit11b33255ed23361f935b4cda8343073e3acf7a98 (patch)
tree198126330cf01795d9151306645fc59919428320 /include/netfilter.mk
parent20fef36448b0d6fa0492e386b9acd5b79bdef84b (diff)
downloadmaster-31e0f0ae-11b33255ed23361f935b4cda8343073e3acf7a98.tar.gz
master-31e0f0ae-11b33255ed23361f935b4cda8343073e3acf7a98.tar.bz2
master-31e0f0ae-11b33255ed23361f935b4cda8343073e3acf7a98.zip
netfilter: move iptable_raw, xt_NOTRACK from conntrack-extra to conntrack
SVN-Revision: 15854
Diffstat (limited to 'include/netfilter.mk')
-rw-r--r--include/netfilter.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/netfilter.mk b/include/netfilter.mk
index 079efb0fb2..ab1749c869 100644
--- a/include/netfilter.mk
+++ b/include/netfilter.mk
@@ -54,6 +54,8 @@ $(eval $(if $(NF_KMOD),$(call nf_add,IPT_CONNTRACK,CONFIG_NF_CONNTRACK_IPV4, $(P
$(eval $(call nf_add,IPT_CONNTRACK,CONFIG_IP_NF_MATCH_STATE, $(P_V4)ipt_state))
$(eval $(call nf_add,IPT_CONNTRACK,CONFIG_NETFILTER_XT_MATCH_STATE, $(P_XT)xt_state))
+$(eval $(call nf_add,IPT_CONNTRACK,CONFIG_IP_NF_RAW, $(P_V4)iptable_raw))
+$(eval $(call nf_add,IPT_CONNTRACK,CONFIG_NETFILTER_XT_TARGET_NOTRACK, $(P_XT)xt_NOTRACK))
# conntrack-extra
@@ -69,10 +71,8 @@ $(eval $(call nf_add,IPT_CONNTRACK_EXTRA,CONFIG_NETFILTER_XT_MATCH_HELPER, $(P_X
$(eval $(call nf_add,IPT_CONNTRACK_EXTRA,CONFIG_IP_NF_MATCH_RECENT, $(P_V4)ipt_recent))
$(eval $(call nf_add,IPT_CONNTRACK_EXTRA,CONFIG_NETFILTER_XT_MATCH_RECENT, $(P_XT)xt_recent))
-$(eval $(call nf_add,IPT_CONNTRACK_EXTRA,CONFIG_IP_NF_RAW, $(P_V4)iptable_raw))
$(eval $(call nf_add,IPT_CONNTRACK_EXTRA,CONFIG_IP_NF_TARGET_CONNMARK, $(P_V4)ipt_CONNMARK))
$(eval $(call nf_add,IPT_CONNTRACK_EXTRA,CONFIG_NETFILTER_XT_TARGET_CONNMARK, $(P_XT)xt_CONNMARK))
-$(eval $(call nf_add,IPT_CONNTRACK_EXTRA,CONFIG_NETFILTER_XT_TARGET_NOTRACK, $(P_XT)xt_NOTRACK))
# extra