summaryrefslogtreecommitdiffstats
path: root/include/kernel.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-12-12 18:28:03 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-12-12 18:28:03 +0000
commitfb5e8d203b87bb8ae21e61b83b344279ba0edb6d (patch)
tree2c05da2f03113a2fa6e696e914bd9265017c1a51 /include/kernel.mk
parentd7b4bf896699bb20e60a072692146514c6058490 (diff)
downloadmaster-31e0f0ae-fb5e8d203b87bb8ae21e61b83b344279ba0edb6d.tar.gz
master-31e0f0ae-fb5e8d203b87bb8ae21e61b83b344279ba0edb6d.tar.bz2
master-31e0f0ae-fb5e8d203b87bb8ae21e61b83b344279ba0edb6d.zip
kernel.mk: Refactor LINUX_KARCH affectation
Switch to a dumber implementation that will be easier to maintain in the long run, with only if statements instead of having nested subst calls. Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com> SVN-Revision: 43671
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk15
1 files changed, 11 insertions, 4 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index d2754abe44..b905cb9e19 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -64,13 +64,20 @@ endif
ifneq (,$(findstring uml,$(BOARD)))
LINUX_KARCH=um
+else ifneq (,$(findstring $(ARCH), aarch64 aarch64_be))
+ LINUX_KARCH := arm64
+else ifneq (,$(findstring $(ARCH), armeb))
+ LINUX_KARCH := arm
+else ifneq (,$(findstring $(ARCH), mipsel mips64 mips64el))
+ LINUX_KARCH := mips
+else ifneq (,$(findstring $(ARCH), sh2 sh3 sh4))
+ LINUX_KARCH := sh
+else ifneq (,$(findstring $(ARCH), i386))
+ LINUX_KARCH := x86
else
- ifeq (,$(LINUX_KARCH))
- LINUX_KARCH=$(strip $(subst i386,x86,$(subst armeb,arm,$(subst mipsel,mips,$(subst mips64,mips,$(subst mips64el,mips,$(subst sh2,sh,$(subst sh3,sh,$(subst sh4,sh,$(subst aarch64,arm64,$(subst aarch64_be,arm64,$(ARCH))))))))))))
- endif
+ LINUX_KARCH := $(ARCH)
endif
-
define KernelPackage/Defaults
FILES:=
AUTOLOAD:=