summaryrefslogtreecommitdiffstats
path: root/include/kernel.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2012-12-16 11:04:27 +0000
committerJohn Crispin <john@openwrt.org>2012-12-16 11:04:27 +0000
commite9c0b958295bb055fefc03b1e356051f99218f28 (patch)
tree2884dc302a0f87ff335a0d5a31a8b9a20384f61b /include/kernel.mk
parent7bcb6b54791ca68ed3433ea0db1bba270d7d0f25 (diff)
downloadmaster-31e0f0ae-e9c0b958295bb055fefc03b1e356051f99218f28.tar.gz
master-31e0f0ae-e9c0b958295bb055fefc03b1e356051f99218f28.tar.bz2
master-31e0f0ae-e9c0b958295bb055fefc03b1e356051f99218f28.zip
fixes uapi helper define
SVN-Revision: 34715
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index eabf9484fa..6185237765 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -35,8 +35,9 @@ else
endif
KERNEL_BUILD_DIR ?= $(BUILD_DIR)/linux-$(BOARD)$(if $(SUBTARGET),_$(SUBTARGET))
LINUX_DIR ?= $(KERNEL_BUILD_DIR)/linux-$(LINUX_VERSION)
- LINUX_UAPI_DIR=$(firstword $(wildcard $(LINUX_DIR)/include/uapi $(LINUX_DIR)/include))
-
+ ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.7.0)),1)
+ LINUX_UAPI_DIR=uapi/
+ endif
LINUX_VERMAGIC:=$(strip $(shell cat $(LINUX_DIR)/.vermagic 2>/dev/null))
LINUX_VERMAGIC:=$(if $(LINUX_VERMAGIC),$(LINUX_VERMAGIC),unknown)