summaryrefslogtreecommitdiffstats
path: root/include/kernel.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-11-19 20:16:50 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-11-19 20:16:50 +0000
commitab92a23394ce9563877be89b17cdc28e1d7d9e25 (patch)
tree7bdde56418df9308dcd3ab8d66abcffbd24af850 /include/kernel.mk
parentac7e0e69bbf5d9976f09da313f3b04936472762c (diff)
downloadmaster-31e0f0ae-ab92a23394ce9563877be89b17cdc28e1d7d9e25.tar.gz
master-31e0f0ae-ab92a23394ce9563877be89b17cdc28e1d7d9e25.tar.bz2
master-31e0f0ae-ab92a23394ce9563877be89b17cdc28e1d7d9e25.zip
build: allow AutoLoad and AutoProbe to specify modules not included in the package
On out-of-tree modules depending on other out-of-tree modules from a different tree, module dependencies are not filled properly. This change helps with adding those dependencies in the AutoLoad call Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 43323
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk12
1 files changed, 4 insertions, 8 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index ae2dcc3fd9..28c8cf8974 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -84,10 +84,8 @@ define ModuleAutoLoad
boot="$$$$$$$$2"; \
shift 2; \
for mod in $$$$$$$$mods; do \
- if [ -e $(2)/$(MODULES_SUBDIR)/$$$$$$$$mod.ko ]; then \
- mkdir -p $(2)/etc/modules.d; \
- echo "$$$$$$$$mod" >> $(2)/etc/modules.d/$(1); \
- fi; \
+ mkdir -p $(2)/etc/modules.d; \
+ echo "$$$$$$$$mod" >> $(2)/etc/modules.d/$(1); \
done; \
if [ -e $(2)/etc/modules.d/$(1) ]; then \
if [ "$$$$$$$$boot" = "1" ]; then \
@@ -103,10 +101,8 @@ define ModuleAutoLoad
boot="$$$$$$$$3"; \
shift 3; \
for mod in $$$$$$$$mods; do \
- if [ -e $(2)/$(MODULES_SUBDIR)/$$$$$$$$mod.ko ]; then \
- mkdir -p $(2)/etc/modules.d; \
- echo "$$$$$$$$mod" >> $(2)/etc/modules.d/$$$$$$$$priority-$(1); \
- fi; \
+ mkdir -p $(2)/etc/modules.d; \
+ echo "$$$$$$$$mod" >> $(2)/etc/modules.d/$$$$$$$$priority-$(1); \
done; \
if [ -e $(2)/etc/modules.d/$$$$$$$$priority-$(1) ]; then \
if [ "$$$$$$$$boot" = "1" ]; then \