summaryrefslogtreecommitdiffstats
path: root/include/kernel.mk
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-07-05 21:31:34 +0000
committerJonas Gorski <jogo@openwrt.org>2015-07-05 21:31:34 +0000
commita6b2271f5df2384fd7d6edd49369b23a73bf8a78 (patch)
tree2f378f3f320f5f6bc7528c5e65cdb30bf2a5a972 /include/kernel.mk
parent761fc3f0353cd404b647d88cb1de05dbc9fd49bb (diff)
downloadmaster-31e0f0ae-a6b2271f5df2384fd7d6edd49369b23a73bf8a78.tar.gz
master-31e0f0ae-a6b2271f5df2384fd7d6edd49369b23a73bf8a78.tar.bz2
master-31e0f0ae-a6b2271f5df2384fd7d6edd49369b23a73bf8a78.zip
kernel: assume modules.builtin is always present
We do not support old kernel versions not generating modules.builtin anymore, so assume it will always be present and check for modules to be built in first. This prevents old modules being packages up after changing the kernel config to include them in the kernel without cleaning the kernel tree. Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 46182
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk14
1 files changed, 5 insertions, 9 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index 300da0d50b..7a0a170c35 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -181,18 +181,14 @@ $(call KernelPackage/$(1)/config)
ifneq ($(if $(SDK),$(filter-out $(LINUX_DIR)/%.ko,$(FILES)),$(strip $(FILES))),)
define Package/kmod-$(1)/install
@for mod in $$(call version_filter,$$(FILES)); do \
- if [ -e $$$$$$$$mod ]; then \
+ if grep -q "$$$$$$$${mod##$(LINUX_DIR)/}" "$(LINUX_DIR)/modules.builtin"; then \
+ echo "NOTICE: module '$$$$$$$$mod' is built-in."; \
+ elif [ -e $$$$$$$$mod ]; then \
mkdir -p $$(1)/$(MODULES_SUBDIR) ; \
$(CP) -L $$$$$$$$mod $$(1)/$(MODULES_SUBDIR)/ ; \
- elif [ -e "$(LINUX_DIR)/modules.builtin" ]; then \
- if grep -q "$$$$$$$${mod##$(LINUX_DIR)/}" "$(LINUX_DIR)/modules.builtin"; then \
- echo "NOTICE: module '$$$$$$$$mod' is built-in."; \
- else \
- echo "ERROR: module '$$$$$$$$mod' is missing." >&2; \
- exit 1; \
- fi; \
else \
- echo "WARNING: module '$$$$$$$$mod' missing and modules.builtin not available, assuming built-in." >&2; \
+ echo "ERROR: module '$$$$$$$$mod' is missing." >&2; \
+ exit 1; \
fi; \
done;
$(call ModuleAutoLoad,$(1),$$(1),$(AUTOLOAD))