summaryrefslogtreecommitdiffstats
path: root/include/kernel.mk
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2011-08-09 12:19:38 +0000
committerJonas Gorski <jogo@openwrt.org>2011-08-09 12:19:38 +0000
commita5f2fd63598414246a497e08a4433a0116f2f606 (patch)
tree3d03ccecc305df938ca4430f8275eea5448267cf /include/kernel.mk
parent33f5b772281e1e3344624938fabeed15563c2b1d (diff)
downloadmaster-31e0f0ae-a5f2fd63598414246a497e08a4433a0116f2f606.tar.gz
master-31e0f0ae-a5f2fd63598414246a497e08a4433a0116f2f606.tar.bz2
master-31e0f0ae-a5f2fd63598414246a497e08a4433a0116f2f606.zip
include/kernel.mk: fix download path for linux 3.x
SVN-Revision: 27939
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index 020779fd63..4744e09ef6 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -48,7 +48,11 @@ else
LINUX_SOURCE:=linux-$(LINUX_VERSION).tar.bz2
TESTING:=$(if $(findstring -rc,$(LINUX_VERSION)),/testing,)
ifeq ($(call qstrip,$(CONFIG_EXTERNAL_KERNEL_TREE)),)
- LINUX_SITE:=@KERNEL/linux/kernel/v$(KERNEL)$(TESTING)
+ ifeq ($(word 1,$(subst ., ,$(KERNEL_BASE))),3)
+ LINUX_SITE:=@KERNEL/linux/kernel/v3.x$(TESTING)
+ else
+ LINUX_SITE:=@KERNEL/linux/kernel/v$(KERNEL)$(TESTING)
+ endif
endif
ifneq ($(TARGET_BUILD),1)